HDU1169-Lowest Bit

Lowest Bit
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7514    Accepted Submission(s): 5517

Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output
For each A in the input, output a line containing only its lowest bit.

Sample Input
26
88
0
 
Sample Output
2
8
 

水题,为了测试强大的itoa函数
itoa函数简介:

功能:将任意类型的数字转换为字符串。在<stdlib.h>中与之有相反功能的函数是atoi。
用法

char *itoa(int value, char *string, int radix);
int value 被转换的整数,char *string 转换后储存的字符数组,int radix 转换进制数,如2,8,10,16 进制等
头文件: <stdlib.h>

比如十进制数n转二进制,可以写itoa(n,a,2)(转换成一个字符串形式的数,a是n转换成的字符型数)

AC代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char s[1000];
int main()
{
    int i,j,n,m,sum,p;
    while(scanf("%d",&n)&&n)
    {
       itoa(n,s,2);
       //printf("%s\n",s);
       m=strlen(s);p=0;
       for(i=m-1;i>=0;i--)
       {
          p++;
          if(s[i]=='1')
          {
             m=p-1;
             break;
          }
       }

       sum=1;
       for(i=m-1;i>=0;i--)
       sum*=2;
       printf("%d\n",sum);
    }
    return 0;
}
时间: 2024-11-08 17:56:14

HDU1169-Lowest Bit的相关文章

[LeetCode]235.Lowest Common Ancestor of a Binary Search Tree

题目 Given a binary search tree (BST), find the lowest common ancestor (LCA) of two given nodes in the BST. According to the definition of LCA on Wikipedia: "The lowest common ancestor is defined between two nodes v and w as the lowest node in T that h

[LeetCode]236.Lowest Common Ancestor of a Binary Tree

题目 Given a binary tree, find the lowest common ancestor (LCA) of two given nodes in the tree.According to the definition of LCA on Wikipedia: "The lowest common ancestor is defined between two nodes v and w as the lowest node in T that has both v and

在应用中加入全文检索功能——基于Java的全文索引引擎Lucene简介

全文检索|索引 内容摘要: Lucene是一个基于Java的全文索引工具包. 基于Java的全文索引引擎Lucene简介:关于作者和Lucene的历史 全文检索的实现:Luene全文索引和数据库索引的比较 中文切分词机制简介:基于词库和自动切分词算法的比较 具体的安装和使用简介:系统结构介绍和演示 Hacking Lucene:简化的查询分析器,删除的实现,定制的排序,应用接口的扩展 从Lucene我们还可以学到什么 基于Java的全文索引/检索引擎--Lucene Lucene不是一个完整的全

Java Collection笔记之ArrayList

1.前言 ArrayList 是一个数组队列,相当于动态数组.与Java中的数组相比,它的容量能动态增长.它继承于AbstractList,实现了List, RandomAccess, Cloneable, java.io.Serializable这些接口. ArrayList 继承了AbstractList,实现了List.它是一个数组队列,提供了相关的添加.删除.修改.遍历等功能. ArrayList实现了RandmoAccess接口,即提供了随机访问功能.RandmoAccess是java

编写可读代码的艺术

这是<The Art of Readable Code>的读书笔记,再加一点自己的认识.强烈推荐此书: 英文版:<The Art of Readable Code> 中文版:编写可读代码的艺术 代码为什么要易于理解 "Code should be written to minimize the time it would take for someone else to understand it." 日常工作的事实是: 写代码前的思考和看代码的时间远大于真正写

UVA之12124 - Assemble

[题目] Problem A - Assemble Time limit: 2 seconds Recently your team noticed that the computer you use to practice for programming contests is not good enough anymore. Therefore, you decide to buy a new computer. To make the ideal computer for your nee

如何过滤 adb logcat 输出

对原作者表示感谢,转自博客:http://www.otechu.me/zh/2011/12/filtering-adb-logcat-output/ 本文介绍如何在 shell 命令行中过滤 adb logcat 输出的几个小技巧. 开发当中经常看到别人的 log 如洪水般瞬间刷满了屏幕,对自己有用的信息都被淹没了,影响心情也影响效率.下面是几个我所知道的过滤方法. 1. 只显示需要的输出,白名单 最方便的当然是通过管道使用 grep 过滤了,这样可以使用 grep 强大的正则表达式匹配.简单的

伴随着Web标准发展

web|web标准 原文作者:Andrei Herasimchuk 原文出处:designbyfire.com 原文发表时间:2004年6月11日 译者前言:这是一篇让人震惊的文章.作者的分析深刻,文笔犀利.作者担心微软会控制整个世界的观点也许偏激,但不得不引起我们的警惕和思考.该文发表后引起了激烈的争论甚至漫骂,感兴趣的建议去原文看看.从中我们能了解web标准在国外推广的真实情况,进而思考我们应该怎样做? 译文 重要提示:下面的文章是我个人的观点,不是为了表现自己或者为我的老板而写. 虽然现在

尽量避免使用中文XML标签

xml|中文 以前参与某标准工作组的工作时,XML标签使用中文还是英文是一个经常的话题和争论焦点.从实现角度来看待这个问题,会倾向于使用英文(我个人一直这样坚持).虽然XML标准要求解析器实现必须支持Unicode,但是不能完全做到支持甚至完全不支持中文XML标签的实现到处都是.如果你的XML文档的目标用户是全球的,那么标签使用ASCII字符是最保险的方式. 强烈要求使用中文的理由一般来说有以下几个: 中文易读(针对国人来说,这是从国情出发:),具有中国特色: 与其他国家或组织交流时,能增加筹码

Operators and Assignments(1)

5)Operators and AssignmentsObjective 1)Determine the result of applying any operator including assignment operators and instanceof to operands of any type class scope or accessibility or any combination of these.1.    Unary operators.1.1    Increment