|
Linux |
Solaris |
HPUX |
AIX |
Mac |
|
||||
Description |
SLES |
RHEL |
Ubuntu |
x86 |
Sparc |
ia64 |
HP-PARISC |
|
|
|
Install package |
rpm -i <package file> |
dpkg -i <package file> |
pkgadd -d <package file> <package> |
swinstall -s <full path to depot> <package name> |
installp -X -d <package file> <package name> |
installer -pkg <package file> -tgt LocalSystem |
||||
Remove package |
rpm -e <package> |
dpkg -r <package> |
pkgrm <package> |
swremove <package name> |
installp -u <package name> |
/usr/libexec/microsoft/domain1/bin/domain1Uninstall.sh (specific for DOMAIN1) |
||||
Upgrade package |
rpm -U <package> |
dpkg -i <package file> |
N.A. |
swinstall -s <full path to depot> <package name> |
|
|
||||
Package info |
rpm -q domain1 |
dpkg -l <package> |
pkginfo -l MSFTdomain1 |
swlist domain1 |
lslpp -l domain1.rte |
pkgutil --pkgs[=<name>] |
||||
Start service |
/etc/init.d/<service> start |
invoke-rc.d <service> start |
svcadm enable <name> Pre10: /etc/init.d/<service> start |
/sbin/init.d/<service> start |
startsrc -s <subsystem> |
launchctl load -w <service path> |
||||
Stop service |
/etc/init.d/<service> stop |
invoke-rc.d <service> stop |
svcadm disable <name> Pre10: /etc/init.d/<service> stop |
/sbin/init.d/<service> stop |
stopsrc -s <subsystem> |
launchctl unload -w <service path> |
||||
Service Status |
/etc/init.d/<service> status |
- |
svcs <name> Pre10: N/A |
/sbin/init.d/<service> status |
lssrc -s <subsystem> |
launchctl -list |
||||
"Top"-command |
top |
prstat |
top |
topas |
top |
|||||
Library path |
LD_LIBRARY_PATH |
|
LD_LIBRARY_PATH |
SHLIB_PATH(32-bit) LD_LIBRARY_PATH(64-bit) |
LIBPATH |
DYLD_LIBRARY_PATH |
||||
Get certificate info |
openssl x509 -in <certificate file (pem format)> -noout -text |
|||||||||
Show exported symbols |
nm <library> |
dump -HTv <library> |
nm <library> |
|||||||
List shared library dependencies |
ldd <file> |
otool -L <file> |
时间: 2024-09-25 02:18:03