POJ1979-Red and Black

Red and Black
Time Limit: 1000MS  Memory Limit: 30000K
Total Submissions: 22250  Accepted: 12011

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output

45
59
6
13

Source

Japan 2004 Domestic

 

 

问题描述:有一间长方形的房子,地上铺了红色、黑色两种颜色的正方形瓷砖。你站在其中一块黑色的瓷砖上,只能向相邻的黑色瓷砖移动。请写一个程序,计算你总共能够到达多少块黑色的瓷砖。

算法:设f(x,y)为从点(x,y)出发能够走过的黑瓷砖总数,则
f(x,y) = 1+f(x-1,y)+f(x+1,y)+f(x,y-1)+f(x,y+1)
这里需要注意,凡是走过的瓷砖不能够被重复走过

AC代码:

#include<stdio.h>
#include<string.h>
//方块四周加白色块,去掉边界判断,
//使得递归统一终止于白色块
int Rank[22][22];
int FindBlack(int c,int l)
{
   if(Rank[c][l]==2)//出口条件(防止重复走)
   return 0;
   else Rank[c][l]=2;
   return 1+FindBlack(c+1,l)+FindBlack(c-1,l)+FindBlack(c,l-1)+FindBlack(c,l+1);//递归函数
}
int main()
{
    int i,j,c,l,n,m;
    char x;
    while(scanf("%d %d",&m,&n),n!=0&&m!=0)
    {
       max=0;
       for(i=0;i<22;i++)
       for(j=0;j<22;j++)
       Rank[i][j]=2;
       for(i=1;i<=n;i++)
       {
          getchar();
          for(j=1;j<=m;j++)
          {
              scanf("%c",&x);
              if(x=='.')
              Rank[i][j]=1;
              else
              {
                 if(x=='#')
                 Rank[i][j]=2;
                 else
                 {
                     c=i;l=j;
                     Rank[i][j]=1;
                 }
              }
          }
       }
       printf("%d\n",FindBlack(c,l));
    }
    return 0;
}
时间: 2025-01-23 23:53:24

POJ1979-Red and Black的相关文章

【OJ】Red and black poj1979 // acmclub.com 6659

#include<iostream> #include<cstdio> using namespace std; char tiles[21][21]; int x,y,w,h,ans; int dx[4]={-1,0,0,1},dy[4]={0,-1,1,0};//^<> void dfs(int sx,int sy){ ans++;tiles[sy][sx]='#'; for(int i=0;i<4;i++){ int nx=sx+dx[i],ny=sy+dy

POJ 1979 Red and Black (DFS)

Time Limit: 1000MS Memory Limit: 30000K Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he ca

&lt;font color=&quot;red&quot;&gt;[置顶]&lt;/font&gt;

Profile Introduction to Blog 您能看到这篇博客导读是我的荣幸,本博客会持续更新,感谢您的支持,欢迎您的关注与留言.博客有多个专栏,分别是关于 Windows App开发 . UWP(通用Windows平台)开发 . SICP习题解 和 Scheme语言学习 . 算法解析 与 LeetCode等题解 . Android应用开发 ,而最近会添加的文章将主要是算法和Android,不过其它内容也会继续完善. About the Author 独立 Windows App 和

Red Hat开源其Hadoop存储系统

  作为大数据+混合云业务战略的一部分,Red Hat没有选择推出自己的hadoop商业版本或者收购一家Hadoop发行厂商,而是推出了首个Hadoop HDFS文件存储系统的开源替代产品. Red Hat本周三宣布开源其Red Hat Storage Hadoop插件,作为HDFS的替代产品.RedHat Storage hadoop插件基于Gluster文件系统--Red Hat于2011年以1.36亿美元收购了Gluster,目前已经将Gluster的技术整合到了Red hat的存储服务器

Red Hat Linux 9 架设FTP服务器的方法

1.安装vsftpd服务器 vsftpd是目前Linux最好的FTP服务器工具之一,其中的vs就是"Very Secure"(很安全)的缩写,可见它的最大优点就是安全,除此之外,它还具有体积小,可定制强,效率高的优点. 如果选择完全安装Red Hat Linux 9.0,则系统会默认安装vsftpd服务器.我们可以在终端命令窗口输入以下 命令进行验证: [root@ahpeng root] rpm -qagrep vsftpd 如果结果显示为"vsftpd-1.1.3-8&q

Oracle 9i Installation on Red Hat Linux

oracle   1, Uncompress and unpack downloaded files   One step procedure (uses less disk space and is faster):  zcat lnx_920_disk1.cpio.gz | cpio -idmv  zcat lnx_920_disk2.cpio.gz | cpio -idmv  zcat lnx_920_disk3.cpio.gz | cpio -idmv Two step procedur

Red Hat Linux 9架设FTP服务器的方法

1.安装vsftpd服务器 vsftpd是目前Linux最好的FTP服务器工具之一,其中的vs就是"Very Secure"(很安全)的缩写,可见它的最大优点就是安全,除此之外,它还具有体积小,可定制强,效率高的优点. 如果选择完全安装Red Hat Linux 9.0,则系统会默认安装vsftpd服务器.我们可以在终端命令窗口输入以下 命令进行验证: [root@ahpeng root] rpm -qagrep vsftpd 如果结果显示为"vsftpd-1.1.3-8&q

Red Hat 4上设置裸设备

在Linux上安装oracle经常会碰到需要使用裸设备的情况,这里就介绍一下Red Hat 4上设置裸设备的方法. 这份文档是在安装好oracle软件的基础上安装的,安装的时候要选择只安装oracle软件. 接下来就是基于裸设备新建数据库了... 1.增加一块硬盘,以root登陆OS [root@rac1 oracle]# fdisk -l Disk /dev/sda: 255 heads, 63 sectors, 652 cylinders Units = cylinders of 16065

轻松安装Red Hat 9.0

对于很多的Linux爱好者来说,你可能曾碰到过这样的问题,在安装系统的时候手边一时没有安装盘,而虽然硬盘上有现成的从网上下载的ISO镜像文件却苦于一时没有刻录机,无法通过刻盘后再进行安装.今天笔者就以Red Hat Linux9.0为例,进行一番由硬盘中的ISO镜像文件进行Red Hat linux 9.0安装的实战. 首先你可以从Red Hat Linux的官方下载站点(ftp.redhat.com/pub/redhat/linux/9/en/iso/i386/)或其他FTP站点下载得到Red

Red Hat的桌面和管理技巧

Red Hat Linux(以下简称Red Hat)是Linux的桌面系统,在Red Hat中使用得最多的就是KDE和GNOME两个桌面环境,在默认情况下安装的是GNOME.如果你在安装系统时没有装KDE软件包的话,那么我们就来看看如何在安装完系统后安装它. 桌面切换 安装完Red Hat并启动计算机,此时将进入GNOME桌面环境.登录后,点击"开始"→"系统设置"→"软件包",随后在"软件包管理"窗口中我们就可以看到有KDE