UVa OJ 120

Background
背景

Stacks and Queues are often considered the bread and butter of data
structures and find use in architecture, parsing, operating systems, and
discrete event simulation. Stacks are also important in the theory of
formal languages.
栈和队列常常被视为数据结构中的面包和黄油,广泛应用在体系结构、分析、操作系统和离散事件等领域。栈同时也在形式语言理论中发挥着重要的作用。

This problem involves both butter and sustenance in the form of
pancakes rather than bread in addition to a finicky server who flips
pancakes according to a unique, but complete set of rules.
这个问题是让一个挑剔的厨师按照独特而完备的一组规则翻动煎饼,以保持煎饼(而不是面包)中的黄油和营养素不被烧坏。(这句话实在不知道怎么翻译才好,还望各位老师指正!Ps. 这道题翻译的难度要比解题大多了!!)

 

The Problem
问题

Given a stack of pancakes, you are to write a program that indicates
how the stack can be sorted so that the largest pancake is on the bottom
and the smallest pancake is on the top. The size of a pancake is given
by the pancake's diameter. All pancakes in a stack have different
diameters.
给定一叠煎饼,你要写一个程序计算出如何才能使这叠煎饼自底向上由大至小的排列。给定煎饼的半径作为其尺寸,一叠煎饼的大小各不相同。

Sorting a stack is done by a sequence of pancake "flips". A flip
consists of inserting a spatula between two pancakes in a stack and
flipping (reversing) the pancakes on the spatula (reversing the
sub-stack). A flip is specified by giving the position of the pancake on
the bottom of the sub-stack to be flipped (relative to the whole
stack). The pancake on the bottom of the whole stack has position 1 and
the pancake on the top of a stack of n pancakes has position n.
为煎饼叠排序是通过一些列的“翻转”动作来完成的。一个翻转动作就是将一个小铲插到煎饼叠中的某两个煎饼之间,然后将小铲上面的所有煎饼翻转(倒转小铲上面的子栈)。每个翻转动作由其开始的位置给出,即小铲上面子栈中最底下一个煎饼的编号。整叠煎饼中最下面一个的位置为1,n个煎饼的叠中最上面一个的位置为n。

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.
一个煎饼叠由一组表示其中各煎饼直径的数构成,它们排列的顺序就是给出的这些数的顺序。

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):
比如下面三个煎饼叠(煎饼8是左边一叠的最上面的一个)

         8           7           2
         4           6           5
         6           4           8
         7           8           4
         5           5           6
         2           2           7

The stack on the left can be transformed to the stack in the middle
via flip(3). The middle stack can be transformed into the right stack
via the command flip(1).
左边一叠可以通过翻转第3个煎饼变成中间一叠的顺序。中间一叠可以通过翻转第1个煎饼变成右边一叠的顺序。

 

The Input
输入

The input consists of a sequence of stacks of pancakes. Each stack
will consist of between 1 and 30 pancakes and each pancake will have an
integer diameter between 1 and 100. The input is terminated by
end-of-file. Each stack is given as a single line of input with the top
pancake on a stack appearing first on a line, the bottom pancake
appearing last, and all pancakes separated by a space.
输入包括一系列煎饼叠。每叠都由1到30个煎饼组成,并且每个煎饼的直径都在 1到100之间。输入由EOF结束。每叠煎饼独占一行,最上面的在行首,最下面的在行尾,各煎饼中间由空格隔开。

 

The Output
输出

For each stack of pancakes, the output should echo the original stack
on one line, followed by some sequence of flips that results in the
stack of pancakes being sorted so that the largest diameter pancake is
on the bottom and the smallest on top. For each stack the sequence of
flips should be terminated by a 0 (indicating no more flips necessary).
Once a stack is sorted, no more flips should be made.
对应于每叠煎饼数据,必须在第一行输出原叠的内容,接下来输出一组翻转动作的序列,使得这一叠煎饼自底向上由大至小的排列。输出的每一组翻转动作序列都要由0来结束(表示不再进行翻转)。一旦一叠煎饼已经排好序,就不能再进行任何翻转。

 

Sample Input
输入示例

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

 

Sample Output
输出示例

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

#include <algorithm>
#include <iostream>
#include <deque>
#include <string>
#include <sstream>
using namespace std;
int main()
{
    for(string strLine;getline(cin,strLine);cout << '0' << endl)
    {
        cout << strLine << endl;
        istringstream iss(strLine);
        deque<int> Stack;
        for(int nDiam; iss >> nDiam;Stack.push_front(nDiam));
        for(deque<int>::iterator it = Stack.begin(); it != Stack.end();++it)
        {
            deque<int>::iterator iMax = max_element(it,Stack.end());
            //如果最大就是it
            if(iMax !=it)
            {
                //如果最大的不是最上面,先最大的反转到最上面
                if(iMax != Stack.end()-1)
                {
                    reverse(iMax,Stack.end());
                    cout << distance(Stack.begin(),iMax) + 1 <<' ';
                }
                //翻转最上面的位置
                reverse(it,Stack.end());
                cout << distance(Stack.begin(),it) + 1 << ' ';
            }
        }
    }
    return 0;
}
时间: 2024-10-29 14:16:47

UVa OJ 120的相关文章

acm-刷ACM的小伙伴进uva oj 455 Periodic Strings,求大神指出我的问题

问题描述 刷ACM的小伙伴进uva oj 455 Periodic Strings,求大神指出我的问题 Periodic Strings A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example the string ""abcabcabcabc&qu

uva-刷ACM小伙伴进Uva oj 340 - Master-Mind Hints

问题描述 刷ACM小伙伴进Uva oj 340 - Master-Mind Hints 如题: Master-Mind Hints MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginnin

uva oj 567 - Risk(Floyd算法)

/* 一张有20个顶点的图上. 依次输入每个点与哪些点直接相连. 并且多次询问两点间,最短需要经过几条路才能从一点到达另一点. bfs 水过 */ #include<iostream> #include<cstring> #include<vector> #include<cstdio> #include<queue> using namespace std; struct node{ int x, step; node(){ } node(in

UVa 10714:Ants

链接: http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=1655 原题: An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant rea

UVa 311:Packets

链接: http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=247 原题: A factory produces products packed in square packets of the same height h and of the sizes , , , , , . These products a

UVa 10148:Advertisement

[链接] http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=1089 [原题] The Department of Recreation has decided that it must be more profitable, and it wants to sell advertising space alo

UVa 10557:XYZZY

题目链接 http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=105&page=show_problem&problem=1498 题目类型: 搜索 题目: The prototypical computer adventure game, first designed by Will Crowther on the PDP-10 in the mid-1970s as

UVa 10004:Bicoloring

题目链接: http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=105 题目类型:搜索 题目: In 1976 the ``Four Color Map Theorem" was proven with the assistance of a computer. This theorem states that every map can be colored using on

UVa 196:Spreadsheet

题目链接: http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=105&page=show_problem&problem=132 题目类型: 搜索, 拓扑排序 题目: In 1979, Dan Bricklin and Bob Frankston wrote VisiCalc, the first spreadsheet application. It became a