HDU 3047 Zjnu Stadium:带权并查集

链接:

http://acm.hdu.edu.cn/showproblem.php?pid=3047

题目:

Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output
For every case:
Output R, represents the number of incorrect request.

Sample Input

10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

Sample Output

2
Hint
Hint: (PS: the 5th and 10th requests are incorrect)

Source
2009 Multi-University Training Contest 14 - Host by ZJNU

题目大意:

有n个人坐在zjnu体育馆里面,然后给出m个他们之间的距离, A B X, 代表B的座位比A多X. 然后求出这m个关系之间有多少个错误,所谓错误就是当前这个关系与之前的有冲突。

分析与总结:

题目有一句话:we assume the number of rows were infinite. 就是假设这个体育馆是无限大的,所以不用考虑圆圈循环的情况。

用带权并查集做, 对于并查集中的每一棵数, 树根的距离为0,然后以树根作为参照,每个结点的权值代表与树根的距离。

合并A,B时,假设A,B属于不同的树,那么就要合并这两棵树, 把A树合并到B树上,这时要给A树的跟结点root_a赋值,关键是给root_a附上一个什么值。 由于A点和B点的权值rank[A]和rank[B]都是相对跟结点的距离,所以分析A,B之间的相对距离,可以得到rank[root_a] = rank[A]+x-rank[B]。 注意到这时,对于原来的A的树,只跟新了root_a跟结点的权值, 那么其它结点的跟新在查找的那一步里面实行了。

代码:

#include<cstdio>
#include<cmath>
using namespace std;
#define N 50005
int f[N], rank[N], n, m;  

void init(){
    for(int i=0; i<=n; ++i)
        f[i]=i, rank[i]=0;
}
int find(int x){
    if(x==f[x]) return f[x];
    int t=f[x];
    f[x] = find(f[x]);
    rank[x] += rank[t];
    return f[x];
}
bool Union(int x,int y, int m){
    int a=find(x), b=find(y);
    if(a==b){
        if(rank[x]+m!=rank[y])
            return false;
        return true;
    }
    f[b] = a;
    rank[b] = rank[x]+m-rank[y];
    return true;
}  

int main(){
    int a,b,x;
    while(~scanf("%d%d",&n,&m)){
        init();
        int cnt=0;
        for(int i=0; i<m; ++i){
            scanf("%d%d%d",&a,&b,&x);
            if(!Union(a, b, x)){
                ++cnt;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}

以上是小编为您精心准备的的内容,在的博客、问答、公众号、人物、课程等栏目也有的相关内容,欢迎继续使用右上角搜索按钮进行搜索is
, The
Incorrect
hdu3047、zjnu.edu.cn、好好经营你的3047岁、acm.zjnu.edu.cn、www.zjnu.edu.cn,以便于您获取更多的相关知识。

时间: 2024-10-28 21:53:05

HDU 3047 Zjnu Stadium:带权并查集的相关文章

HDU 3038 How Many Answers Are Wrong? :带权并查集

链接: http://acm.hdu.edu.cn/showproblem.php?pid=3038 题目: Problem Description TT and FF are ... friends. Uh... very very good friends -________-b FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. T

hdu 3047 Zjnu Stadium

点击打开链接hdu 3047 思路: 带权并查集 分析: 1 题目要求的是错误的条件的个数,这一题还是比较简单的带权并查集 2 我们用rank[x]表示的x到跟节点的距离,那么对于x和y来说,如果x和y在不同集合那么把x和y合并,否则直接判断rank[x] == (rank[y]+val)%300 代码: #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> usi

HDU 2818 Building Block, poj 1988 Cube Stacking:带权并查集

链接: HDU: http://acm.hdu.edu.cn/showproblem.php?pid=2818 POJ:  http://poj.org/problem?id=1988 题目: Problem Description John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N.Initially, there are N piles, and each pile contai

hdu3635 Dragon Balls(带权并查集)

/* 题意:有N个城市, 每一个城市都有一个龙珠(编号与城市的编号相同),有两个操作 T A ,B 将标号为A龙珠所在城市的所有的龙珠移动到B龙珠所在城市中! 思路:并查集 (压缩路径的时候将龙珠移动的次数进行更新) */ #include<iostream> #include<cstring> #include<cstdio> #include<algorithm> #define M 10005 using namespace std; int f[M]

poj 1733 Parity game:带权并查集

链接: http://poj.org/problem?id=1733 题目: Description Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the

HDU 3938 Portal(离线+Kruskal+并查集)

链接: http://acm.hdu.edu.cn/showproblem.php?pid=3938 题目: Problem Description ZLGG found a magic theory that the bigger banana the bigger banana peel .This important theory can help him make a portal in our universal. Unfortunately, making a pair of por

HDU 1811 Rank of Tetris(拓扑排序+并查集)

链接: http://acm.hdu.edu.cn/showproblem.php?pid=1811 题目: Problem Description 自从Lele开发了Rating系统,他的Tetris事业更是如虎添翼,不久他遍把这个游戏推向了全球. 为了更好的符合那些爱好者的喜好,Lele又想了一个新点子:他将制作一个全球Tetris高手排行榜,定时更新,名堂要比福布斯富豪榜还响.关于如何排名,这个不用说都知道是根据Rating从高到低来排,如果两个人具有相同的Rating,那就按这几个人的R

HDU 2473 Junk-Mail Filter 【并查集+设立虚父节点(马甲)】

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=2473 原题: Problem Description Recognizing junk mails is a tough task. The method used here consists of two steps: 1) Extract the common characteristics from the incoming email. 2) Use a filter matching t

HDU 1829 A Bug&#039;s Life(基础种类并查集)

链接: http://acm.hdu.edu.cn/showproblem.php?pid=1829 原题: Problem Description Background Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with b