UVa 10921 Find the Telephone (water ver.)

10921 - Find the Telephone

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1862

In some places is common to remember a phone number associating its digits to letters. In this way the expression MY LOVE means 69 5683. Of course there are some problems, because some phone numbers can not form a word or a phrase and the digits 1 and 0 are not associated to any letter.

Your task is to read an expression and find the corresponding phone number based on the table below. An expression is composed by the capital letters (A-Z), hyphens (-) and the numbers 1 and 0.

Letters Number
ABC 2
DEF 3
GHI 4
JKL 5
MNO 6
PQRS 7
TUV 8
WXYZ 9

Input

The input consists of a set of expressions. Each expression is in a line by itself and has C characters, where 1 ≤ C ≤ 30. The input is terminated by enf of file (EOF).

Output

本文URL地址:http://www.bianceng.cn/Programming/sjjg/201410/45354.htm

For each expression you should print the corresponding phone number.

Sample Input

1-HOME-SWEET-HOME
MY-MISERABLE-JOB

Sample Output

1-4663-79338-4663
69-647372253-562

完整代码:

/*0.018s*/

#include<cstdio>
#include<cctype>
#include<cstring>
const char num[] = {" 22233344455566677778889999"};  

char str[35];  

int main()
{
    int len, i;
    while (gets(str))
    {
        len = strlen(str);
        for (i = 0; i < len; ++i)
            putchar(isalpha(str[i]) ? num[str[i] & 31] : str[i]);
        putchar(10);
    }
    return 0;
}

以上是小编为您精心准备的的内容,在的博客、问答、公众号、人物、课程等栏目也有的相关内容,欢迎继续使用右上角搜索按钮进行搜索include
, phone
, str
, and
, expression
, The
1862
en10921法兰标准、en10921中文版、en10921法兰尺寸、法兰en10921、短信10921 10086,以便于您获取更多的相关知识。

时间: 2024-11-16 18:24:11

UVa 10921 Find the Telephone (water ver.)的相关文章

UVa 10656 Maximum Sum (II) (water ver.)

10656 - Maximum Sum (II) Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1597 In a given a sequence of non-negative integers you will have to find such a

UVa 12640 Largest Sum Game (water ver.)

12640 - Largest Sum Game Time limit: 1.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=602&page=show_problem&problem=4388 题目:http://uva.onlinejudge.org/external/126/12640.pdf 主要是读取数据怎么处理. 完整代码: /*0

UVa 10019 Funny Encryption Method (water ver.)

10019 - Funny Encryption Method Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=960 The Problem History : A student from ITESM Campus Monterrey plays with

UVa 10346 Peter&#039;s Smokes (water ver.)

10346 - Peter's Smokes Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1287 Peter has n cigarettes. He smokes them one by one keeping all the butts. Out o

UVa 11498 Division of Nlogonia (water ver.)

11498 - Division of Nlogonia Time limit: 1.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=2493 The Problem After centuries of hostilities and skirmishes between the fo

UVa 457 Linear Cellular Automata (water ver.)

457 - Linear Cellular Automata Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=94&page=show_problem&problem=398 A biologist is experimenting with DNA modification of bacterial colonie

UVa 11044 Searching for Nessy (water ver.)

11044 - Searching for Nessy Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=99&page=show_problem&problem=1985 The Loch Ness Monsteris a mysterious and unidentified animal said to inha

UVa 102 Ecological Bin Packing (water ver.)

102 - Ecological Bin Packing Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=38 Background Bin packing, or the placement of objects of certain weights int

UVa 10008 What&#039;s Cryptanalysis? (water ver.)

10008 - What's Cryptanalysis? Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=949 Cryptanalysis is the process of breaking someone else's cryptographic wr