HDOJ 1004题 Let the Balloon Rise strcmp()函数

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color
and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case
letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input


5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output


red
pink

代码:

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;

int main()
{
    int n,i,j,s=1,b[1010],f[1010];
    char a[1010][20];
    while(~scanf("%d",&n)&&n)
    {
        memset(b,0,sizeof(b));
        for(i=0; i<n; i++)
        {
            scanf("%s",a[i]);
        }
        for(i=0; i<n; i++)
        {
            f[i]=1;
            for(j=i+1; j<n; j++)
            {
                if(b[j]==0)
                {

                    if(strcmp(a[i],a[j])==0)//这里我不知道为什么用a[i]==a[j]就不可以,求大神评论解释一下,谢谢了
                    {
                        b[j]=1;
                        f[i]=f[i]+1;
                    }
                }
            }
        }
        int s=0;
        for(i=0; i<n; i++)
        {
            if(f[s]<=f[i])
            {
                s=i;
            }
        }
        printf("%s\n",a[s]);
    }
    return 0;
}
				
时间: 2024-10-27 17:48:16

HDOJ 1004题 Let the Balloon Rise strcmp()函数的相关文章

PHP中strnatcmp()函数“自然排序算法”进行字符串比较用法分析(对比strcmp函数)_php技巧

本文实例讲述了PHP中strnatcmp()函数"自然排序算法"进行字符串比较用法.分享给大家供大家参考,具体如下: PHP中strnatcmp()函数使用"自然"算法来比较两个字符串(区分大小写),通常在自然算法中,数字 2 小于数字 10.而在计算机排序中,10 小于 2,这是因为 10 中的第一个数字小于 2. strnatcmp()函数的定义如下: strnatcmp(string1,string2) 参数说明: string1  必需.规定要比较的第一个字

c语言-strcmp()函数的使用问题

问题描述 strcmp()函数的使用问题 明明相等的两个数组为什么判断相等得到的返回值不是0? 解决方案 strcmp函数的使用strcmp函数的使用的一个坑matlab中strcmp函数的使用 解决方案二: 这个strcmp是自己实现的? 怎么有三个参数 解决方案三: strcmp函数的用法是strcmp(str1,str2),同时字符串要以""结尾,否则不知会比出什么结果 解决方案四: 数组,当参数用后变为指针,但你的数组没有结束符,所以比较了不至6个字符,它会一直比较到遇到字符串

(一)strcmp函数

(一)strcmp函数            strcmp函数是比较两个字符串的大小,返回比较的结果.一般形式是:                    i=strcmp(字符串,字符串);          其中,字符串1.字符串2均可为字符串常量或变量:i   是用于存放比较结果的整型变量.比较结果是这样规定的:   ①字符串1小于字符串2,strcmp函数返回一个负值; ②字符串1等于字符串2,strcmp函数返回零; ③字符串1大于字符串2,strcmp函数返回一个正值;那么,字符中的大

php函数 strcmp函数实例教程

定义和用法 该strcmp ( )函数比较两个字符串. 这个函数返回: 0 -如果这两个字符串相等 " 0 -如果字符串小于字符串 " 0 -如果字符串大于字符串 语法 strcmp(string1,string2) Parameter Description string1 必需的.指定的第一个字串比较 string2 必需的.指定第二个字符串比较 提示和说明注: strcmp ( )函数是二进制安全和区分大小写. 例如 <?php echo strcmp("Hell

strcmp函数实现及分析

最近看C,看到strcmp函数,对它的实现原型不很清楚,于是到网上搜.网上算法一大堆,看了很多代码后自己做了一下总结  strcmp函数是C/C++中基本的函数,它对两个字符串进行比较,然后返回比较结果,函数形式如下:int strcmp(const char* str1, const char* str2); 其中str1和str2可以是字符串常量或者字符串变量,返回值为整形.返回结果如下规定: ① str1小于str2,返回负值或者-1(VC返回-1):                   

HDOJ 1004 Let the Balloon Rise

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color

[ACMcoder] Let the Balloon Rise

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color

HDOJ 1312题Red and Black

Red and Black Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13508 Accepted Submission(s): 8375 Problem Description There is a rectangular room, covered with square tiles. Each tile is colored ei

HDOJ 1004

#include<stdio.h> #include<string.h> typedef struct//二维数组没有这个方便 { char str[16]; int num; }Node; int main() { Node col[1001]; int T,i,j,max; while(~scanf("%d",&T),T) { getchar(); for(i=1;i<=T;i++) col[i].num=0; for(i=1;i<=T;