HDOJ 1004

#include<stdio.h>
#include<string.h>
typedef struct//二维数组没有这个方便
{
    char str[16];
    int num;
}Node;
int main()
{
    Node col[1001];
    int T,i,j,max;
    while(~scanf("%d",&T),T)
    {
        getchar();
        for(i=1;i<=T;i++)
            col[i].num=0;
        for(i=1;i<=T;i++)
        {
            scanf("%s",col[i].str);
            getchar();
            for(j=1;j<=i;j++)
                if(strcmp(col[j].str,col[i].str)==0)
                col[i].num++;
        }
        max=0;
        j=1;
        for(i=1;i<=T;i++)
        {
            if(col[i].num>max)
            {
                max=col[i].num;
                j=i;
            }
        }
        printf("%s\n",col[j].str);
    }
}

 

Sample Input

5 green red blue red red 3 pink orange pink 0

 

 

Sample Output

red pink

 

 

时间: 2024-10-13 18:23:24

HDOJ 1004的相关文章

HDOJ 1004题 Let the Balloon Rise strcmp()函数

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color

HDOJ 1004 Let the Balloon Rise

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color

HDOJ 1004(字符串分类统计)

#include<stdio.h> #include<string.h> typedef struct//二维数组没有这个方便 { char str[16]; int num; }Node; int main() { Node col[1001]; int T,i,j,max; while(~scanf("%d",&T),T) { getchar(); for(i=1;i<=T;i++) col[i].num=0; for(i=1;i<=T;

vba运行时错误1004怎么解决

  vba运行时错误1004怎么解决         在EXCEL这款软件中,有些用户使用到VBA,在一些测试中,偶尔会遇到软件的错误提示,比如错误1004.这通常是VBA就运行报错的结果,那么,vba运行时错误1004怎么解决呢?接下来小编就告诉大家vba运行时错误1004怎么办. 这段代码是测试当前VBA版本的: 复制代码 代码如下: Sub 获取VBA版本() MsgBox Application.VBE.Version End Sub 当按F5键,就报:运行时错误1004.经老师指点,单

杭电1004

题目地址: http://acm.hdu.edu.cn/showproblem.php?pid=1004 参考代码: #include<stdio.h> #include <stdlib.h> #include <string.h> void main() { int i,n,j,max,tmp; char ctmp[16]; while (scanf("%d",&n)&&n) { char (*p)[16] = (char(

http-ios9 afnetworking请求数据 错误code=-1004

问题描述 ios9 afnetworking请求数据 错误code=-1004 真机iPad mini2,iOS9.1,已经在info.plist中增加 <key>NSAppTransportSecurity</key><dict> <key>NSAllowsArbitraryLoads</key> <true/></dict> 但是不起作用,怎么办呢啊!!!谢谢!!!!!! 解决方案 参考:http://www.ruan

最大匹配-HDOJ 2458 Kindergarten

HDOJ 2458 Kindergarten Description In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids 

最大匹配-HDOJ 1068

HDOJ 1068 Girls and Boys . Problem Description the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study

【PAT】 1004成绩排名

1004. 成绩排名 (20) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue 读入n名学生的姓名.学号.成绩,分别输出成绩最高和成绩最低学生的姓名和学号. 输入格式:每个测试输入包含1个测试用例,格式为 第1行:正整数n 第2行:第1个学生的姓名 学号 成绩 第3行:第2个学生的姓名 学号 成绩 ... ... ... 第n+1行:第n个学生的姓名 学号 成绩 其中姓名和学号均为不超过10个字符的字符串,成绩