HDOJ/HDU 2700 Parity(奇偶判断~)

Problem Description
A bit string has odd parity if the number of 1’s is odd. A bit string has even parity if the number of 1’s is even.Zero is considered to be an even number, so a bit string with no 1’s has even parity. Note that the number of
0’s does not affect the parity of a bit string.

Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only “#” that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter ‘e’ or a lowercase letter ‘o’.

Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was ‘e’) or odd parity (if the letter was ‘o’).

Sample Input
101e
010010o
1e
000e
110100101o
#

Sample Output
1010
0100101
11
0000
1101001010

英文题~看懂题意就ok了。
e代表的是偶数奇偶性校验。
o代表的是奇数奇偶性校验。
0代表是。1代表否~
其实就是判断1的个数~

import java.util.Scanner;

/**
 * @author 陈浩翔
 */
public class Main{

    public static void main(String[] args) {
        Scanner sc= new Scanner(System.in);
        while(sc.hasNext()){
            String str = sc.next();
            if(str.equals("#")){
                return ;
            }
            int num=0;
            for(int i=0;i<str.length()-1;i++){
                if(str.charAt(i)=='1'){
                    num++;
                }
            }
            if(num%2==0){//1出现的次数为偶数
                if(str.charAt(str.length()-1)=='e'){//偶数奇偶校验
                    //0代表判断正确
                    System.out.println(str.substring(0, str.length()-1)+'0');
                }else{
                    System.out.println(str.substring(0, str.length()-1)+'1');
                }
            }else{
                if(str.charAt(str.length()-1)=='o'){//奇数奇偶校验
                    //0代表判断正确
                    System.out.println(str.substring(0, str.length()-1)+'0');
                }else{
                    System.out.println(str.substring(0, str.length()-1)+'1');
                }
            }
        }
    }
}
时间: 2024-09-23 05:46:55

HDOJ/HDU 2700 Parity(奇偶判断~)的相关文章

加减乘除 判断奇偶-关于加减乘数实现奇偶判断

问题描述 关于加减乘数实现奇偶判断 我有数字1到100,现在程序中只有 + - * / > < >= <= <> == 想实现判断奇偶数,系统中 没有%(取余)这个参数,求各位大神,帮忙实现一下,谢谢. 我开始考虑 通过小数和整数来判断 但是系统 还是没有 判断整数和小数的函数. 只有 加 减 乘 除 大于 小于 小于等于 大于等于 不等于 等于 这些条件.求各位大神 帮帮忙,小弟在此感谢大家. 解决方案 把那个数除以2再乘以2,看结果是不是和原有的数值相等. 解决方案

HDOJ/HDU 2163 Palindromes(判断回文串~)

Problem Description Write a program to determine whether a word is a palindrome. A palindrome is a sequence of characters that is identical to the string when the characters are placed in reverse order. For example, the following strings are palindro

HDOJ/HDU 2562 奇偶位互换(交换位置~)

Problem Description 给定一个长度为偶数位的0,1字符串,请编程实现串的奇偶位互换. Input 输入包含多组测试数据: 输入的第一行是一个整数C,表示有C测试数据: 接下来是C组测试数据,每组数据输入均为0,1字符串,保证串长为偶数位(串长<=50). Output 请为每组测试数据输出奇偶位互换后的结果: 每组输出占一行. Sample Input 2 0110 1100 Sample Output 1001 1100 水题一个~~~~ 就是交换相邻奇偶的值 而且这个值只有

HDOJ/HDU 2203 亲和串(简单的判断~Java的indexOf()方法秒)

Problem Description 人随着岁数的增长是越大越聪明还是越大越笨,这是一个值得全世界科学家思考的问题,同样的问题Eddy也一直在思考,因为他在很小的时候就知道亲和串如何判断了,但是发现,现在长大了却不知道怎么去判断亲和串了,于是他只好又再一次来请教聪明且乐于助人的你来解决这个问题. 亲和串的定义是这样的:给定两个字符串s1和s2,如果能通过s1循环移位,使s2包含在s1中,那么我们就说s2 是s1的亲和串. Input 本题有多组测试数据,每组数据的第一行包含输入字符串s1,第二

HDOJ/HDU 2555 人人都能参加第30届校田径运动会了(判断加排序~)

Problem Description 杭州师范大学第29届田径运动会圆满的闭幕了,本届运动会是我校规模最大,参赛人数最多的一次运动会.在两天半时间里,由学生.教工组成的61支代表队共2664名运动员参加了比赛.比赛期间,运动健儿赛出了风格.赛出了水平,共有9人次打破6项校纪录. 我们寝室的4名同学是我班最卖力的啦啦队员,每天都在看台上为班级里的运动员们加油助威,为我班获得精神文明奖立下了汗马功劳.可是遗憾的是,与我校的其他近2万名同学一样,我们自己不能上场表演 :( 于是,我们4名同学为下一届

HDOJ(HDU) 2143 box(简单的多次判断-用的卫条件)

Problem Description One day, winnie received a box and a letter. In the letter, there are three integers and five operations(+,-,*,/,%). If one of the three integers can be calculated by the other two integers using any operations only once.. He can

HDOJ/HDU 2537 8球胜负(水题.简单的判断)

Problem Description 8球是一种台球竞赛的规则.台面上有7个红球.7个黄球以及一个黑球,当然还有一个白球.对于本题,我们使用如下的简化规则:红.黄两名选手轮流用白球击打各自颜色的球,如果将该颜色的7个球全部打进,则这名选手可以打黑球,如果打进则算他胜.如果在打进自己颜色的所有球之前就把黑球打进,则算输.如果选手不慎打进了对手的球,入球依然有效. 现在给出打进的球(白球除外)的顺序,以及黑球由哪方打进,你的任务是判定哪方是胜者. 假设不会有一杆同时打进一颗黑球和其他彩球. Inp

HDOJ(HDU) 1976 Software Version(简单判断)

Problem Description 相信大家一定有过在网上下载软件而碰到多个不同版本的情况. 一般来说,软件的版本号由三个部分组成,主版本号(Major Version Number),子版本号(Minor Version Number)和修订号(Revision_Number).当软件进行了重大的修改时,主版本号加一:当软件在原有基础上增加部分功能时,主版本号不变,子版本号加一:当软件仅仅修正了部分bug时,主版本号和子版本号都不变,修正号加一. 在我们比较软件的两个版本的新旧时,都是先比

HDOJ/HDU 1180 诡异的楼梯(经典BFS-详解)

Problem Description Hogwarts正式开学以后,Harry发现在Hogwarts里,某些楼梯并不是静止不动的,相反,他们每隔一分钟就变动一次方向. 比如下面的例子里,一开始楼梯在竖直方向,一分钟以后它移动到了水平方向,再过一分钟它又回到了竖直方向.Harry发现对他来说很难找到能使得他最快到达目的地的路线,这时Ron(Harry最好的朋友)告诉Harry正好有一个魔法道具可以帮助他寻找这样的路线,而那个魔法道具上的咒语,正是由你纂写的. Input 测试数据有多组,每组的表