cisco上的RIP V2加上MD5认证配置测试成功

R1:

Router#show run
Building configuration...

Current configuration : 1133 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
!
key chain RIP-MK5-KEY
 key 1
  key-string ripv2md5
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 12.0.0.1 255.255.255.0
 ip rip authentication mode md5
 ip rip authentication key-chain RIP-MK5-KEY
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 21.0.0.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 version 2
 passive-interface Loopback0
 network 1.0.0.0
 network 12.0.0.0
 network 21.0.0.0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

 

R2:

Router#show run
Building configuration...

Current configuration : 1059 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
!
key chain RIP-MK5-KEY
 key 1
  key-string ripv2md5
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 12.0.0.2 255.255.255.0
 ip rip authentication mode md5
 ip rip authentication key-chain RIP-MK5-KEY
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 23.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 21.0.0.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 version 2
 network 12.0.0.0
 network 21.0.0.0
 network 23.0.0.0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

 

拓朴结构同前.

测试过程:

时间: 2025-01-01 22:00:21

cisco上的RIP V2加上MD5认证配置测试成功的相关文章

在PS上为文字切片加上超链接方法

  我们在做网站或装修店铺的时候,往往要为文字加上超链接,这更多的运用是给自制的导航条图片文字加上链接网址,要做到这一切一般情况下是需要DW软件的,而手头上只有PS该怎么办?下面我们就来谈谈用PS怎样为图片文字加上链接. 方法/步骤 首先打开PS软件,新建一个长1024像素X50像素的导航条,再用着色按钮涂上你喜欢的颜色,如图所示: 然后,进一步美化一下导航条.新建一个图层,接着依次点击:图层--图层样式--斜面和浮雕.在弹出的对话框中慢慢调节移动滑块,直到你认为比较满意位置,点击确定后,如图所

破解-修改数据 MD5认证 绕过

问题描述 修改数据 MD5认证 绕过 有些数据在传输的时候有MD5认证,不能修改数据内容,.请问这种情况有办法解决吗?绕过认证,或是破解认证? 解决方案 MD5是单向的,也就是不可破解的;如果数据经过MD5加密后存到了数据库中,我想你还是想其他的办法吧,破解是不行的了:网上有在线破解的网站,你可以试试:

Nginx中的用户认证配置及阻止用户使用代理访问的方法_nginx

nginx用户认证配置( Basic HTTP authentication)ngx_http_auth_basic_module模块实现让访问着,只有输入正确的用户密码才允许访问web内容.web上的一些内容不想被其他人知道,但是又想让部分人看到.nginx的http auth模块以及Apache http auth都是很好的解决方案. 默认情况下nginx已经安装了ngx_http_auth_basic_module模块,如果不需要这个模块,可以加上 --without-http_auth_

Nginx用户认证配置方法详解(域名/目录)_nginx

Nginx可以为某一个域名单独加用户认证,具体做法如下: 1. 生成用户认证的用户名和密码: 复制代码 代码如下: #wget -c soft.vpser.net/lnmp/ext/htpasswd.sh;bash htpasswd.sh 根据提示输入: 用户名:密码:文件名: 脚本会自动生成认证文件,auth.conf内容如下: 复制代码 代码如下: /usr/local/nginx/conf/auth.conf 2. 为Nginx添加auth认证配置 下面以某域名下面的auth目录为例,在域

Nginx用户认证配置方法(域名/目录)详解

Nginx可以为某一个域名单独加用户认证,具体做法如下: 1. 生成用户认证的用户名和密码:  代码如下 复制代码 #wget -c soft.vpser.net/lnmp/ext/htpasswd.sh;bash htpasswd.sh 根据提示输入: 用户名: 密码: 文件名: 脚本会自动生成认证文件,auth.conf内容如下:  代码如下 复制代码 /usr/local/nginx/conf/auth.conf 2. 为Nginx添加auth认证配置 下面以某域名下面的auth目录为例,

nginx用户认证配置( Basic HTTP authentication)

ngx_http_auth_basic_module模块实现让访问着,只有输入正确的用户密码才允许访问web内容.web上的一些内容不想被其他人知道,但是又想让部分人看到.nginx的http auth模块以及Apache http auth都是很好的解决方案. 默认情况下nginx已经安装了ngx_http_auth_basic_module模块,如果不需要这个模块,可以加上 --without-http_auth_basic_module . nginx basic auth指令 语法:  

Qmail+vpopmail+daemontools+ucspi邮件系统安装及SMTP认证配置

最近线上的一台qmail邮件系统因硬件出现故障,又重新部署了新的Qmail邮件系统,在网上查阅了好多关于qmail安装资料,下面是我整理的qmail安装和SMTP认证配置文档. 准备条件: 系统:centos 5.5 64位 安装qmail邮件系统依赖的相关软件包 yum install g++ gcc-g++ gdbm gdbm-devel openssl openssl-devel stunnel krb5-devel bzip2 bzip2-devel 然后删除系统自带的邮件系统,以免安装

盘点国际上一些权威的杀毒软件认证与测试

[51CTO.com综合消息]伴随着互联网应用的日益广泛,互联网安全问题也备受关注.杀毒软件自然也就成为用户电脑中的"常客".近年来,杀毒软件市场的竞争越发激烈,你方唱罢,我登场,用户也有点乱花渐欲迷人眼的感觉,如何选择一款好用.实用的杀毒软件,成为广大网民最关心的问题.09年,伴随着国产杀毒软件频频出击国际市场,国内的用户也开始关注国际上的一些比较权威的杀毒软件测试.那么,这些所谓的权威测试到底牛在哪里?对用户选择杀毒软件是否有参考价值?带着这些问题,小编对国际上一些权威的杀毒软件认

Apache与Nginx登录认证配置详解(可认证目录)

一.Apache认证 认证的类型:Basic Digest摘要 认证方法:A.容器认证:<Directory> --</Directory> B.隐藏文件认证创建.htaccess文件 方法一.容器认证 A.进入配置文件vi /etc/httpd/conf/httpd.conf B.配置:大约在531行附近配置如下:  代码如下 复制代码 <Directory "/var/www/html/mrtg"> AllowOverride None##不允许