UVa 10237 Bishops:组合数学

10237 - Bishops

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1178

A bishop is a piece used in the game of chess which is played on a board of square grids. A bishop can only move diagonally from its current position and two bishops attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for bishop B1 form its current position.  The figure also shows that the bishops B1 and B2 are in attacking positions whereas B1 andB3 are not. B2 and B3 are also in non-attacking positions.

Now, given two numbers n and k, your job is to determine the number of ways one can put k bishops on an n × n chessboard so that no two of them are in attacking positions.

Input

The input file may contain multiple test cases. Each test case occupies a single line in the input file and contains two integers n (1 ≤ n ≤ 30) andk (0 ≤ k ≤ n2).

A test case containing two zeros for n and k terminates the input and you won’t need to process this particular input.

Output

For each test case in the input print a line containing the total number of ways one can put the given number of bishops on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1015.

Sample Input
8 6
4 4
20 40
30 5
0 0

Sample Output
5599888
260
0
3127859642656

完整代码:

/*0.049s*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int M = 30 + 5;
const int N = 30 * 30 + 5;  

ll Rb[M][N], Rw[M][N], B[M], W[M]; /// B=Black, W=White  

void calc(int n, int k, ll R[][N], ll C[])
{
    int i, j;
    memset(R, 0, sizeof(R));
    for (i = 0; i <= n; i++)
        R[i][0] = 1;
    for (i = 1; i <= n; i++)
        for (j = 1; j <= C[i]; j++)
            R[i][j] = R[i - 1][j] + R[i - 1][j - 1] * (C[i] - j + 1);
}  

int main()
{
    int i, j, n, k;
    ll ans;
    while (scanf("%d%d", &n, &k), n)
    {
        memset(B, 0, sizeof(B));
        memset(W, 0, sizeof(W));
        for (i = 1; i <= n; i++)
            for (j = 1 ; j <= n; j++)
            {
                if ((i + j) & 1) ++W[(i + j) >> 1];
                else ++B[(i + j) >> 1]; ///计算黑和白的对角线格子数,这样写就不用考虑n的奇偶性
            }
        sort(B + 1, B + n + 1);
        sort(W + 1, W + n);
        calc(n, k, Rb, B);
        calc(n - 1, k, Rw, W);///分别计算白格和黑格上的方案数
        ans = 0;
        for (i = 0; i <= k; i++)
            ans += Rb[n][i] * Rw[n - 1][k - i];
        printf("%lld\n", ans);
    }
    return 0;
}

查看本栏目更多精彩内容:http://www.bianceng.cnhttp://www.bianceng.cn/Programming/sjjg/

以上是小编为您精心准备的的内容,在的博客、问答、公众号、人物、课程等栏目也有的相关内容,欢迎继续使用右上角搜索按钮进行搜索input
, include
, number
, and
, of
The
乐高10237、lego 10237、inkydoom 10237、10237、乐高10237评测,以便于您获取更多的相关知识。

时间: 2024-09-19 02:59:41

UVa 10237 Bishops:组合数学的相关文章

UVa 861 Little Bishops (组合数学)

861 - Little Bishops Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=36&page=show_problem&problem=802 A bishop is a piece used in the game of chess which is played on a board of squar

UVa 11609 Teams (组合数学)

11609 - Teams Time limit: 1.000 seconds http://uva.onlinejudge.org/index.php? option=com_onlinejudge&Itemid=8&category=467&page=show_problem&problem=26 56 In a galaxy far far away there is an ancient game played among the planets. The spec

UVa 10157 Expressions:组合数学&amp;amp;高精度

10157 - Expressions Time limit: 10.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=34&page=show_problem&problem=1098 Let X be the set of correctly built parenthesis expressions. The elements of X a

UVa 10198 Counting:组合数学&amp;amp;高精度

10198 - Counting Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1139 The Problem Gustavo knows how to count, but he is now learning how write numbers. As

UVa 10247 Complete Tree Labeling:组合数学&amp;amp;高精度

10247 - Complete Tree Labeling Time limit: 15.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1188 A complete k-ary tree is a k-ary tree in which all leaves have same d

UVa 10254 The Priest Mathematician:组合数学&amp;amp;规律发现&amp;amp;高精度

10254 - The Priest Mathematician Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=34&page=show_problem&problem=1195 The ancient folklore behind the "Towers of Hanoi" puzzle i

UVa 12208 How Many Ones Needed? (组合数学)

12208 - How Many Ones Needed? Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=onlinejudge&Itemid=99999999&category=244&page=show_problem&problem=3360 水. 完整代码: /*0.035s*/ #include<bits/stdc++.h> using namespace s

UVa 10994 Simple Addition :组合数学

10994 - Simple Addition Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=115&page=show_problem&problem=1935 计算sum{i从右往左数的第一个非0数字,p<=i<=q}. 见代码.. 01./*0.016s*/ 02. 03.#include<

UVa 11076 Add Again (组合数学)

11076 - Add Again Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php? option=com_onlinejudge&Itemid=8&category=467&page=show_problem&problem=20 17 Summation of sequence of integers is always a common problem in Computer Science