UVa 11729 - Commando War(贪心)

“Waiting for orders we held in the wood, word from the front never came
By evening the sound of the gunfire was miles away
Ah softly we moved through the shadows, slip away through the trees
Crossing their lines in the mists in the fields on our hands and our knees
And all that I ever, was able to see
The fire in the air, glowing red, silhouetting the smoke on the breeze”
There is a war and it doesn’t look very promising for your country. Now it’s time to act. You
have a commando squad at your disposal and planning an ambush on an important enemy camp
located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a
unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that
everyone can focus on his task only. In order to enforce this, you brief every individual soldier about
his tasks separately and just before sending him to the battlefield. You know that every single soldier
needs a certain amount of time to execute his job. You also know very clearly how much time you
need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you
need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers
to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his
fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing
in between.

Input

There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤
N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two
integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while
completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case
should not be processed.

Output

For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the
total number of seconds counted from the start of your first briefing till the completion of all jobs.

Sample Input
3
2 5
3 2
2 1
3
3 3
4 4
5 5
0

Sample Output
Case 1: 8
Case 2: 15

题意:
你有n个部下,每个部下需要完成一项任务。第i个部下需要你花B(i)分钟交代任务,
然后他就会立刻独立的、无间断的执行J(i)分钟后完成任务。
你需要选择交代任务的顺序,使得所有任务尽早执行完毕(即最后一个执行完的任务应尽早结束)。
注意:不能同时给2个或以上的部下交代任务,但部下们可以同时执行他们各自的任务。

输入第一行为n,n为部下的个数。
接下来的n行为B和J。
当n为0时,输入结束。

分析:
执行时间较长的任务需要先交代,
于是,我们可以想到这样一个贪心算法:
按照J从小到大的顺序给各个任务排序,然后依次交代。

package cn.hncu.UVa;

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

/**
 *
 * @author 陈浩翔
 *
 * 2016-4-25
 */
public class P11729 {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int k=0;
        while(sc.hasNext()){
            k++;
            int n =sc.nextInt();
            if(n==0){
                break;
            }
            Bj bj[] = new Bj[n];
            for(int i=0;i<n;i++){
                bj[i]=new Bj();
                bj[i].b = sc.nextInt();
                bj[i].j = sc.nextInt();
            }
            sort(bj);
            int s=0;
            int ans =0;
            for(int i=0;i<n;i++){
                s = s+bj[i].b;//当前任务的开始执行时间,也就是吩咐完后的时间
                ans = Math.max(ans, s+bj[i].j);//更新用户任务执行完毕时的最晚时间
            }
            System.out.println("Case "+k+": "+ans);
        }
    }

    private static void sort(Bj[] bj) {
        Arrays.sort(bj, new Comparator<Bj>() {
            @Override
            public int compare(Bj o1, Bj o2) {
                if(o1.j<o2.j){
                    return 1;
                }
                return -1;
            }
        });
    }
}

class Bj{
    public int b;
    public int j;
}
时间: 2024-09-21 01:22:33

UVa 11729 - Commando War(贪心)的相关文章

uva 11729 - Commando War

点击打开链接uva 11729 思路:贪心 分析: 1 给定n个人的交待任务的时间和完成任务的时间,要求不能同时给两个人交代任务,但是可以多人同时去做任务,求最短的完成任务的时间 2 根据贪心的原则,我们知道执行时间比较长的任务必须先交待,于是我们只要对这n个任务按照完成任务的时间进行排序,然后枚举n个人进去求解即可. 代码: #include<cstring> #include<cstdio> #include<iostream> #include<algori

UVA 之11729 - Commando War

There is a war and it doesn't look very promising for your country. Now it's time to act. You have a commando squad at your disposal and planning an ambush on an important enemy camp located nearby. You have N soldiers in your squad. In your master-p

UVa 10148 Advertisement:贪心&amp;amp;标记法单个处理

10148 - Advertisement Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=1089 The Department of Recreation has decided that it must be more profitable, and

UVa 10720:Graph Construction

链接: http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=1661 原题: Graph is a collection of edges E and vertices V. Graph has a wide variety of applications in computer. There are diffe

UVa 10382:Watering Grass

链接: http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=1323 原题: n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed

uva 11292 - Dragon of Loowater

点击打开链接uva 11292 思路:贪心 分析: 1 能力强的骑士开价高是合理的,但是如果排去砍一个很弱的头那就是浪费人才了,所以呢我们把骑士的能力值和头的直径进行排序,然后一个砍一个这样就可以了,最后判断是否把所有的头全部砍完即可 代码: #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using namespace std; const int MAXN

uva 11039 - Building designing

点击打开链接uva 11039 思路:贪心(排序+枚举) 分析: 1 题目要求按照题目给定的数据求能够建立最高几层的楼房 2 题目要求上层的大小要比下层小,并且两层之间的颜色要交替的出现.很明显,我们只要按照size进行排序,然后枚举即可. 代码: #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using namespace std; const int M

UVa 1267 Network:DFS&amp;amp;贪心

1267 - Network Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=456&page=show_problem&problem=3708 Consider a tree network with n nodes where the internal nodes correspond to servers a

CERC 2004 / UVa 1335 Beijing Guards:二分&amp;amp;贪心&amp;amp;想法题

1335 - Beijing Guards Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=456&page=show_problem&problem=4081 Beijing was once surrounded by four rings of city walls: the Forbidden City Wa