hdu 5349 MZL's simple problem

hdu 5349 的传送门

Problem Description

A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)

Input

The first line contains a number N (N≤106),representing the number of operations.
Next N line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than 109.

Output

For each operation 3,output a line representing the answer.

Sample Input

6
1 2
1 3
3
1 3
1 4
3

Sample Output

3
4

题目大意:给你一个数,表示有几行,然后给你一个a和x,如果a等于1的话,就向里面增加一个数,如果a等于2的话 ,就删除集合中最小的一个数,如果等于a==3 的话,就输出最大的数;
解题思路:STL,集合;

具体见代码:

#include <iostream>
#include <cstdio>
#include <set>
using namespace std;
set<long long >::iterator it;
set<long long > s;

int main()
{
    long long n, a, x;
    scanf("%lld",&n);
    s.clear();
    while(n--)
    {
        scanf("%lld",&a);
        if(a == 1)
        {
            scanf("%lld",&x);
            s.insert(x);
        }
        else if(a == 2)
        {
            if(!s.empty())
               s.erase(s.begin());
        }
        else if(a == 3)
        {
            if(s.empty())
                puts("0");
            else
            {
                it=s.end();
                it--;
                printf("%lld\n",*it);
            }
        }
    }
    return 0;
}
时间: 2024-10-31 09:41:16

hdu 5349 MZL&#39;s simple problem的相关文章

hdu 5334 MZL&amp;#39;s xor

hdu 5334 的传送门 MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1≤i,j≤n) The xor of an array B is defined as B1 xor B2-xor Bn Input Multiple test cases, the first line contains an integer T(no

【北大夏令营笔记-线段树】POJ3468-A Simple Problem with Integers

A Simple Problem with Integers Time Limit: 5000MS Memory Limit: 131072K Total Submissions: 57993 Accepted: 17658 Case Time Limit: 2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of ope

hd2522A simple problem

A simple problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3118    Accepted Submission(s): 1135 Problem Description Zty很痴迷数学问题..一天,yifenfei出了个数学题想难倒他,让他回答1 / n.但Zty却回答不了^_^. 请大家编程帮助他.   I

hdu 3509 Buge&amp;#39;s Fibonacci Number Problem

点击此处即可传送 hdu 3509 题目大意:F1 = f1, F2 = f2;; F(n) = a*F(n-1) + b*F(n-2); S(n) = F1^k + F2^k +-.+Fn^k; 求S(n) mod m; 解题思路: 1:首先一个难题就是怎么判断矩阵的维数(矩阵的维数是个变量) 解决方法:开一个比较大的数组,然后再用一个公有变量记一下就行了,具体详见代码: 2:k次方,找规律: 具体上代码吧: /* 2015 - 8 - 16 晚上 Author: ITAK 今日的我要超越昨日

hdu 1250 Hat&amp;#39;s Fibonacci

点击此处即可传送hdu 1250 Problem Description A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) Your

【HDU 4738 Caocao&amp;#39;s Bridges】BCC 找桥

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4738 题意:给定一个n个节点m条边的无向图(可能不连通.有重边),每条边有一个权值.判断其连通性,若双连通,输出-1:若非连通,输出0:否则,输出权值最小的桥的权值. 思路:进行双连通域分解,记下连通块的个数和所有桥的情况,对应输出结果即可. 注意对重边的处理.这里我按照上一道题学到的姿势如法炮制:先把所有边按"字典序"排序(u, v, w),这样重边聚集在一起了,然后扫描一遍,发现重边即

hdu 5280 Senior&amp;#39;s Array

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5280 问题描述 某天学姐姐得到了一个数组A ,在这个数组的所有非空区间中,她找出了一个区间和最大的,并把这个区间和定义为这个数组的美丽值. 但是她觉得这个数组不够美,于是决定修理一下这个数组. 学姐姐将会进行一次操作,把原数组中的某个数修改为P (必须修改). 最后她想使得修改后的数组尽可能美丽.请你帮助她计算经过修理后,这个数组的美丽值最大能是多少? #include <iostream> #i

hdu 5281 Senior&amp;#39;s Gun

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5281 题目大意:学姐姐是一个酷酷的枪手. 她常常会随身携带n 把枪,每把枪有一个攻击力a[i] . 有一天她遇到了m 只怪兽,每只怪兽有一个防御力b[j] .现在她决定用手中的枪消灭这些怪兽. 学姐姐可以用第i 把枪消灭第j 只怪兽当且仅当b[j]≤a[i] ,同时她会获得a[i]−b[j] 的分数. 每把枪至多只能使用一次,怪兽死后也不会复活.现在学姐姐想知道她最多能得到多少分(她可以不用消灭所有

hdu 4282 A very hard mathematic problem

点击打开链接hdu 4282 1思路:   枚举z的范围(2-31),然后枚举x的值1->pow(x,z)>=k/2,最后二分查找y的值即可.2分析:  1由公式可以知道z的范围是2-31,但是x和y的范围不好确定,所以暴力肯定TLE.                2这种类似的题目一般都是固定两个然后在二分查找第三个.                3注意二分查找的时候用到(left+right)/2,所以数据类型要为long long 这样才不会超出int(这个地方WA了N次,不解释),还