UVa 10110 Light, more light:数论

10110 - Light, more light

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=100&page=show_problem&problem=1051

The Problem
There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off?

The Input
The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.
The Output
Output "yes" if the light is on otherwise "no" , in a single line.
Sample Input

3
6241
8191
0

Sample Output

no
yes
no

注意一开始所有灯泡都是关着的。

简化:我们只需要计算满足i|n的i的个数(即n的因子数)的奇偶性即可。

注意到当n不是完全平方数的时候,n=a*b中a一定不等于b,此时n有偶数个因子。

反之当n为完全平方数时,n一定有奇数个因子。

完整代码:

/*0.039s*/

#include<cstdio>
#include<cmath>  

int main()
{
    unsigned int n;///注意数据范围
    int m;
    while (scanf("%d", &n), n)
    {
        m = (int)sqrt(n);
        puts(m * m == n ? "yes" : "no");
    }
    return 0;
}

查看本栏目更多精彩内容:http://www.bianceng.cn/Programming/sjjg/

以上是小编为您精心准备的的内容,在的博客、问答、公众号、人物、课程等栏目也有的相关内容,欢迎继续使用右上角搜索按钮进行搜索int
, input
, output
, is
The
uva10110、more than light、more than light 下载、more. light、shed more light on,以便于您获取更多的相关知识。

时间: 2024-12-02 23:18:33

UVa 10110 Light, more light:数论的相关文章

UVa 10791 Minimum Sum LCM (数论&amp;amp;素因子分解)

10791 - Minimum Sum LCM Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php? option=com_onlinejudge&Itemid=8&category=467&page=show_problem&problem=17 32 LCM (Least Common Multiple) of a set of integers is defined as the minimum

算法题:UVA 106 Fermat vs. Pythagoras(数论)

Fermat vs. Pythagoras Background Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and curr

CSS 滤镜——Mask,Light滤镜

css|滤镜 Mask 滤镜语法 {filter:mask(color=color)} 使用"MASK"属性可以为对象建立一个覆盖于表面的膜,其效果就象戴着有色眼镜看物体一样 . 原表格拷屏   CSS 滤镜效果实现欢迎光临天极设计在线 效果拷屏 Light 滤镜 Light 滤镜语法 {filter:light} 这个属性模拟光源的投射效果.一旦为对象定义了"LIGHT"滤镜属性,那么就可以调用它的"方法(Method)"来设置或者改变属性.&

OpenGL ES From the Ground Up, Part 4: Let There Be Light!

FRIDAY, MAY 1, 2009 OpenGL ES From the Ground Up, Part 4: Let There Be Light! Continuing on with OpenGL ES for the iPhone, let's talk about light. So far, we haven't done anything with light. Fortunately, OpenGL still lets us see what's going on if w

Redux教程2:链接React

序 通过前面的教程,我们有了简单的环境,并且可以运行 Redux 的程序,也对 如何编写Redux示例 有了初步的印象: 掌握了 使用Redux控制状态转移,继而驱动 React 组件发生改变,这才是学习Redux的初衷. 本篇我们将 Redux 和 React 联合起来,着重讲解 redux-react 模块的使用: 1.编写红绿灯React组件 在原有的基础上,我们编写红绿灯组件: touch components/light/index.js components/light/index.

css font-weight原理

为什么要记录一下?因为今天我要设置一个字符加粗,然后就用font-weight:200,没有任何效果.现在看来很可笑,400才相当于normal,200怎么加粗,奇怪的是也没有变细.所以得研究一下font-weight的工作原理,以下正文. 一.使用介绍 font-weight设置文本的粗细,文本粗细设置属于一种比较复杂的字体样式定义,之所以说它复杂,是因为字体本身粗细变化千变万化,没有统一标准,对于字体粗细的具体定义也各不相同. 属性值:normal | bold | bolder | lig

XML入门教程:XML 浏览器支持

xml|教程|浏览器|入门教程 几乎所有的主流浏览器均支持XML和XSLT. Mozilla Firefox 从1.0.2版本开始,Firefox就已开始支持XML和XSLT(包括CSS). Mozilla Mozilla含有用于XML解析的Expat,并支持显示XML + CSS.Mozilla同时拥有对Namespaces的某些支持. Mozilla同样可做到对XSLT的执行(XSLT implementation). Netscape 自从版本8开始,Netscape开始使用Mozilla

使用CSS滤镜的方法

css|滤镜 具体的应用有两种方法: 1. 先定义好CSS ,再在页面中需要的对象上使用预先定义好的CSS,实际上CSS的设置对话框里已经预先将这些滤镜的语法设置好了,我们只需填上适合的具体参数即可: 2.直接在支持CSS滤镜效果的HTML控件元素上编写CSS filter代码. a.Alpha 滤镜 "Alpha"属性是把一个目标元素与背景混合.设计者可以指定数值来控制混合的程度.这种"与背景混合"通俗地说就是一个元素的透明度.通过指定坐标,可以指定各种不同范

Fireworks 8 混合模式详解

详解 翻译:梦觉 http://www.bitgenius.com [ 下载实例文件 ](文件大小16.5M,包含三个PNG源文件,英文版PDF格式源教程) Fireworks 8整合了大量有趣的功能,但在我看来,其中最酷的一个就是新增的26种混合模式.这些新增的混合模式打开了一个创造性潜能的世界.我无法不接受它,因为我是一个Fireworks痴迷者.我在Fireworks中处理大量的图形,同时我也不断的尝试.创造各种可能的效果.新的混合模式给了Fireworks一个更广阔的舞台. 混合模式可以