HDOJ/HDU 1321 Reverse Text(倒序输出~)

Problem Description
In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.

Input
The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.

Output
For each test case, print a line containing the characters of the input line in reverse order.

Sample Input
3
Frankly, I don’t think we’ll make much
money out of this scheme.
madam I’m adam

Sample Output
hcum ekam ll’ew kniht t’nod I ,ylknarF
.emehcs siht fo tuo yenom
mada m’I madam

就是输入一行字符串,然后倒序输出就可以了~

import java.util.Scanner;

/**
 * @author 陈浩翔
 * 2016-5-25
 */
public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =sc.nextInt();
        sc.nextLine();//读取数字后的回车
        while(t-->0){
            String str =sc.nextLine();
            for(int i=str.length()-1;i>=0;i--){
                System.out.print(str.charAt(i));
            }
            System.out.println();
        }
    }
}
时间: 2024-12-30 22:30:44

HDOJ/HDU 1321 Reverse Text(倒序输出~)的相关文章

将字符串或数字倒序输出

将字符串或数字倒序输出,以使这些呈散列分布,用于作为hbase rowkey的一部分,避免region的读写热点 public class StringUtil { public static void main(String[] args) { long start = System.currentTimeMillis(); for (int i = 0; i < 10; i++) { System.out.println(reverseLong(78945612399l)); } Syste

怎样设计程序将一个int数字或一组字符倒序输出,分别用java和C语言实现

问题描述 怎样设计程序将一个int数字或一组字符倒序输出,分别用java和C语言实现 如:输入 输出 123 321 abc cba 解决方案 这个最快:头位=0, 尾位=数据.length-1 static void 翻筋斗云(int[] 数据, int 头位, int 尾位=数据) { while (头位 < 尾位) { int 交换 = 数据[头位]; 数据[头位++] = 数据[尾位]; 数据[尾位--] = 交换; } } 解决方案二: 这个我刚好写过哎,int就用n=n+t%10;t

java-我要求当前系统的年份月份,然后进行倒序输出.该怎么做呢,求大神帮忙

问题描述 我要求当前系统的年份月份,然后进行倒序输出.该怎么做呢,求大神帮忙 SimpleDateFormat sd=new SimpleDateFormat("yyyy-MM"); System.out.println(sd.format(new Date())); String date=sd.format(new Date()); System.out.println(date+"--"); long time=0; time=1*24*60*60*1000;

iostream-C++怎么使用递归实现数组前N个元素倒序输出

问题描述 C++怎么使用递归实现数组前N个元素倒序输出 顺便看一下这个该怎么改 #include <iostream> using namespace std; int n; int fun(int str[]); int main() { int str[101]; for(int i=0;i<=100;) { str[i] = i++; } int n; cout << "输入:" << endl; cin >> n; fun(

ios-IOS中怎样把一个字符串倒序输出

问题描述 IOS中怎样把一个字符串倒序输出 在IOS开发中,怎么把一个字符串倒序输出?如 NSString *string = @""qwer"";怎样输出一个字符串为 rewq . 解决方案 NSString *string = @""qwer""; NSMutableString *newString = [[NSMutableString alloc] initWithCapacity:string.length]; f

java数组的倒序输出。

问题描述 java数组的倒序输出. 使其变为 a ba cba dcba ---- 怎么才可以做到呢?用for循环可以么? 解决方案 /* package whatever; // don't place package name! */ import java.util.*; import java.lang.*; import java.io.*; /* Name of the class has to be "Main" only if the class is public.

c# 字符串 倒序输出-请问各位一个C#字符串倒序输出的问题

问题描述 请问各位一个C#字符串倒序输出的问题 大家好,新学C#,在字符串倒序输出时遇到了一点问题,想请问大家. static void Main(string[] args) { Console.WriteLine("请输入字符串:"); int i; string myString = Console.ReadLine(); for (i = myString.Length - 1; i >= 0; i--) { Console.WriteLine("转换后的字符串

c++-C++的递归实现数组中的前n个元素实现倒序输出的问题

问题描述 C++的递归实现数组中的前n个元素实现倒序输出的问题 请问以下程序有什么问题 #include <iostream> using namespace std; void fun(int str1[], int a); int main() { int str[101]; for(int i=0;i<=101;) { str[i] = i-1; } int n; cin >> n; fun(str, n); return 0; } void fun(int str1[

数组的倒序输出是意思?要排序吗?还是简单的从尾到前输出??

问题描述 数组的倒序输出是意思?要排序吗?还是简单的从尾到前输出??定义一个int数组,请倒序输出所有的元素 解决方案 解决方案二:数组的倒序输出,不要排序,就是从后往前输出的意思如果要数组中元素倒序输出的话,那就要先排序,然后再根据要求输出了解决方案三:那这个题目呢??解决方案四:数组顺序输出从第0个元素,输出到第length-1个元素倒序输出从第length-1个元素到第0个元素解决方案五:加油,