HDOJ 1715

点击打开链接

简单的大数相加

上代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int s[1010][250];
void f()
{
    memset(s,0,sizeof(s));
    s[1][0]=1;s[2][0]=1;
    for(int i=3;i<=1000;i++){
        for(int j=0;j<250;j++){
            s[i][j]+=s[i-1][j]+s[i-2][j];
            if(s[i][j]>=10){
               s[i][j]=s[i][j]%10;
               s[i][j+1]++;
            }
        }
    }
}
int main()
{
    int n,t,c;
    f();
    cin>>t;
    while(t--){
        cin>>n;
        c=249;
        while(c--){
            if(s[n][c]!=0)
                break;
        }
        for(;c>=0;c--)
            cout<<s[n][c];
        cout<<endl;
    }
    return 0;
}
时间: 2024-10-01 00:13:57

HDOJ 1715的相关文章

HDOJ 1715 大菲波数

Problem Description Fibonacci数列,定义如下: f(1)=f(2)=1 f(n)=f(n-1)+f(n-2) n>=3. 计算第n项Fibonacci数值. Input 输入第一行为一个整数N,接下来N行为整数Pi(1<=Pi<=1000). Output 输出为N行,每行为对应的f(Pi). Sample Input 5 1 2 3 4 5 Sample Output 1 1 2 3 5 属于水题吧,用java大数做的. import java.math.B

最大匹配-HDOJ 2458 Kindergarten

HDOJ 2458 Kindergarten Description In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids 

最大匹配-HDOJ 1068

HDOJ 1068 Girls and Boys . Problem Description the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study

hdoj 1007 两点之间最短距离的二分之一 提交之后超时了 求c语言解法 感激不敬

问题描述 hdoj 1007 两点之间最短距离的二分之一 提交之后超时了 求c语言解法 感激不敬 #include"stdio.h" #include"math.h" int main() { int n,i,j; double s; while(scanf("%d",&n)&&n) { double a[100000][5]={0}; for(i=0;i<n;i++) for(j=0;j<2;j++) sca

HDOJ/HDU 1161 Eddy&amp;#39;s mistakes(大写字母转换成小写字母)

Problem Description Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely disco

HDOJ 2057 A + B Again

Problem Description There must be many A + B problems in our HDOJ , now a new one is coming. Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too. Easy ? AC it ! Input The input contains severa

HDOJ 2033 人见人爱A+B

Problem Description HDOJ上面已经有10来道A+B的题目了,相信这些题目曾经是大家的最爱,希望今天的这个A+B能给大家带来好运,也希望这个题目能唤起大家对ACM曾经的热爱. 这个题目的A和B不是简单的整数,而是两个时间,A和B 都是由3个整数组成,分别表示时分秒,比如,假设A为34 45 56,就表示A所表示的时间是34小时 45分钟 56秒. Input 输入数据有多行组成,首先是一个整数N,表示测试实例的个数,然后是N行数据,每行有6个整数AH,AM,AS,BH,BM,

HDOJ 1001Sum Problem

Problem Description Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge). In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + - + n. Input The input will consist of a series of integers n, one integer per line. Output For each ca

HDOJ 1316

点击打开链接 首先打表,然后就是比较了,比较恶心了一点,注意用compare比较 8  12会有 8>12,注意一下比较函数 测试数据: input: 83 346930886 77 214636915 93 424238335 86 149760492 49 189641421 62 350490027 ouput : 32 31 31 30 32 32 代码: #include<iostream> #include<cstring> #include<cstdio&