HDOJ(HDU) 2107 Founding of HDU(找最大值)

Problem Description
经过慎重的考虑,XHD,8600, LL,Linle以及RPG等ACM队员集体退役,甚至正在酝酿退学。
为什么?要考研?那也不用退学呀…
当然不是!真正的原因是他们想提前创业,想合伙成立一家公司,据说公司的名称都想好了,为了感谢多年的ACM集训队队长XHD,公司就叫海东集团(HaiDong Union),简称HDU.(对于这个公司名称,几个人私下里开玩笑说,外面的人看到HDU,可别以为是”胡捣集团”,呵呵)
公司成立了,谁来做老大呢?这对于合伙的公司可是一个难题。好在几位同学经过几年的ACM训练,思维非常活跃,马上想到推选AC战斗力最强的一位来做老总。
现在的问题就是,假设每人的AC战斗力是一个已知的整数,请编程输出最后选出的老总的AC战斗力。

Input
输入包含多组测试数据,每组数据占2行,首先一行是一个整数n(n<100),表示创立公司的人数,然后一行是n个32位整数,表示n个人的AC战斗力,n为0的时候结束输入。

Output
对于每个测试实例,请输出老总的AC战斗力,每个实例的输出占一行。

Sample Input
3
1 2 3
0

Sample Output
3

到了这个程度,看到这样的题目,这个就属于超级水题了。。。
就是找最大的值。


import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n==0){
                return ;
            }
            int a[] = new int[n];
            int max=sc.nextInt();
            for(int i=0;i<n-1;i++){
                a[i]=sc.nextInt();
                if(max<a[i]){
                    max=a[i];
                }
            }
            System.out.println(max);
        }
    }
}
时间: 2024-10-22 04:55:30

HDOJ(HDU) 2107 Founding of HDU(找最大值)的相关文章

HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)

Problem Description 在上一回,我们让你猜测海东集团用地的形状,你猜对了吗?不管结果如何,都没关系,下面我继续向大家讲解海东集团的发展情况: 在最初的两年里,HDU发展非常迅速,综合各种ACM算法生成的老鼠药效果奇好,据说该药专对老鼠有效,如果被人误食了,没有任何副作用,甚至有传闻说还有健胃的效果,不过这倒没有得到临床验证.所以,公司的销量逐年递增,利润也是节节攀升,作为股东之一的公主负责财务,最近半年,她实在辛苦,多次因为点钞票造成双手抽筋而住院,现在在她面前你根本不要提到"

hdu 2109 (Fighting for HDU)

http://acm.hdu.edu.cn/showproblem.php?pid=2109 水题 #include <iostream> #include <algorithm> #include <cstdio> using namespace std; int data1[105]; int data2[105]; int main() { int m; while(cin>>m,m) { int sum1=0,sum2=0; for(int i=0;

HDOJ 2114 Calculate S(n)(找周期)

Problem Description Calculate S(n). S(n)=1^3+2^3 +3^3 +--+n^3 . Input Each line will contain one integer N(1 < n < 1000000000). Process to end of file. Output For each case, output the last four dights of S(N) in one line. Sample Input 1 2 Sample Ou

hdu 2108 Shape of HDU

提示叉积: 代码如下: #include <iostream> #include <cstdio> #include <cmath> using namespace std; struct point { int x; int y; }a[50]; int fun(int i,int j,int k) //叉积 { return (a[j].x-a[i].x)*(a[k].y-a[j].y)-(a[k].x-a[j].x)*(a[j].y-a[i].y); } int

HDU 3339 In Action:最短路+背包

链接: http://acm.hdu.edu.cn/showproblem.php?pid=3339 题目: Problem Description Since 1945, when the first nuclear bomb was exploded by the Manhattan Project team in the US, the number of nuclear weapons have soared across the globe. Nowadays,the crazy bo

HDU 2489 Minimal Ratio Tree (DFS枚举+最小生成树Prim)

链接: HDU : http://acm.hdu.edu.cn/showproblem.php?pid=2489 POJ  : http://poj.org/problem?id=3925 题目: Problem Description For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation. Given a comp

【HDU 2013 猴子吃桃子】 尾递归与迭代

大一时的一道C语言练习题,可作为递归和尾递归转迭代的范例.HDU 2013 http://acm.hdu.edu.cn/showproblem.php?pid=2013 题意:猴子摘了sum个桃子,从第1天开始,每天吃掉剩余桃子的一半多一个,第n天时只剩1个桃子,求sum值. 分析:设第 i 天在开吃之前所剩的桃子数为sum(i),第 i 天要吃掉的桃子数为f(i), 则问题可表示为:已知sum(n)=1 和如下两个关系式: f(i) = sum(i)/2 + 1 (1) sum(i+1) =

JS中取二维数组中最大值的方法汇总_javascript技巧

在JavaScript中可以通过内置的 Math.max() 的最大值,但是要从多重数组中取出最大值,还是有一定的难度. 问题描述 假设你有一个数组,而且这个数组中包含了数字的子数组,而我们要做的是从数组中的每个子数组中返回其最大的那个最大数. 基本解决方案 function largestOfFour(arr) { var results = []; // 创建一个results变量来存储 // 创建一个外层循环,遍历外层数组 for (var n = 0; n < arr.length; n

【DP专辑】ACM动态规划总结

转载请注明出处,谢谢.   http://blog.csdn.net/cc_again?viewmode=list          ----------  Accagain  2014年5月15日 动态规划一直是ACM竞赛中的重点,同时又是难点,因为该算法时间效率高,代码量少,多元性强,主要考察思维能力.建模抽象能力.灵活度. 本人动态规划博客地址:http://blog.csdn.net/cc_again/article/category/1261899 ******************