2802: 判断字符串是否为回文
Description
编写程序,判断输入的一个字符串是否为回文。若是则输出“Yes”,否则输出“No”。所谓回文是指順读和倒读都是一样的字符串。
Input
Output
Sample Input**
abcddcba
Sample Output
Yes
参考解答:
#include<stdio.h>
#include<string.h>
int main()
{
char s[100];
int i,j;
gets(s);
i=0;
j=strlen(s)-1;
while(s[i]==s[j]&&i<=j)
{
i++;
j--;
}
if(i>j)
printf("Yes\n");
else
printf("No\n");
return 0;
}
时间: 2024-10-27 02:05:20