uva-刷ACM小伙伴进Uva oj 340 - Master-Mind Hints

问题描述

刷ACM小伙伴进Uva oj 340 - Master-Mind Hints

如题: Master-Mind Hints

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code tex2html_wrap_inline35 and a guess tex2html_wrap_inline37 , and are to determine the hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i,j), tex2html_wrap_inline41 and tex2html_wrap_inline43 , such that tex2html_wrap_inline45 . Match (i,j) is called strong when i = j, and is called weak otherwise. Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0
Sample Output

Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)

    大概意思就是猜数字的一个游戏,给定答案序列和用户猜的序列,统计有多少数字正确(A),有多少数字在两个序列都出现过但位置不对(B)。
    ps.猜测序列正常情况下数字只可能是1~9中的某一个。
    输入包含多组数据。每组输入第一行为序列长度为n,第二行是答案序列,接下来是若干猜测序列。猜测序列全零则该组数据结束。n=0输入结束。
    下面是我的代码:
#include <stdio.h>
int a[1050],b[1050];
int main()
{
    int n,round=0;
    while(scanf("%d",n)==1&&n){
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        printf("Game %d:n",++round); //用round记录第几轮
        int num1=0,num2=0;
        for(;;){
            int c1=0,c2=0;
            for(int i=1;i<=n;i++){
                scanf("%d",&b[i]);
                if(b[i]==a[i])
                    num1++;   //直接统计可得A
                for(int j=1;j<=9;j++){
                    if(a[i]==j) c1++;
                    if(b[i]==j) c2++;
                }
            }
            if(b[1]==0) break;
            if(c1<c2)
                num2+=c1;
            else
                num2+=c2;
            printf("    (%d,%d)n",num1,num2-num1);
        }
    }
    return 0;
}

最后编译没问题,可是出现dos窗口输入一个数字enter后就狗带了

就像下面这样,求大神解答啊囧

解决方案

你的程序指针有问题,参考
http://www.cnblogs.com/SDUTYST/archive/2012/06/02/2532196.html
http://blog.csdn.net/zcube/article/details/8461796

解决方案二:

第一个while的scanf的n少了&,但是跑完你的答案是不对的。。

  while(scanf("%d",&n)==1&&n){

解决方案三:

重新梳理了下逻辑,现在应该行了

#include <stdio.h>
int a[1050],b[1050];
int main()
{
    int n,round=0;
    while(scanf("%d",&n)==1&&n){
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        round++;
        printf("Game %d:n",round);
        for(;;){
            int num1=0,num2=0;
            for(int i=1;i<=n;i++){ //猜测序列赋值
                scanf("%d",&b[i]);
                if(b[i]==a[i]) num1++;
            }
            if(b[1]==0) break;
            for(int j=1;j<=9;j++){
                int c1=0,c2=0;  //在每一轮数字统计时初始化c1,c2
                for(int i=1;i<=n;i++){
                    if(a[i]==j) c1++;//c1记录在答案序列某数字的个数
                    if(b[i]==j) c2++;//c2记录在猜测序列中某数字的个数
                }
                if(c1<c2)
                    num2+=c1;
                else
                    num2+=c2;
                //c1,c2两者取其小
            }
            printf("    (%d,%d)n",num1,num2-num1);
        }
    }
    return 0;
}

时间: 2024-09-09 09:54:28

uva-刷ACM小伙伴进Uva oj 340 - Master-Mind Hints的相关文章

acm-刷ACM的小伙伴进uva oj 455 Periodic Strings,求大神指出我的问题

问题描述 刷ACM的小伙伴进uva oj 455 Periodic Strings,求大神指出我的问题 Periodic Strings A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example the string ""abcabcabcabc&qu

acm-ACM的小伙伴进,uva-1584有些小问题求大神解惑

问题描述 ACM的小伙伴进,uva-1584有些小问题求大神解惑 Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence CGAGTCAGCT", that is, the last symbolT" in CGAGTCAGCT" is connected to the first symbolC". We alway

写给一心刷ACM题目的学生

[来信] 老师你好,我大2013级大二的学生.大一时自学了数据结构,大二的时候参加了ACM. 现在寒假在家里刷题.可是我还想学习些东西,比如深入C 的学习,或者java.但是感觉除了刷题之外,就很迷茫,不知道以后出去工作是C 好还是java好.其实我更喜欢C ,但是如何去深入学习C 呢,我对C 的深入学习也是很迷茫的,因为对于C/C 除了用来刷题,我都不知道他们能够干什么? [回复] 你没有说你的专业,我猜想应该是计算机类的专业.下面就基于这个前提,谈谈我的想法. 很高兴你能找到一个提高编程能力

UVa 10596:Morning Walk, 赤裸裸的欧拉回路

题目链接: http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=105&page=show_problem&problem=1537 题目类型: 欧拉回路, 并查集, dfs 题目: Kamal is a Motashota guy. He has got a new job in Chittagong. So, he has moved to Chittagong fr

photoshop如何载入笔刷|载入笔刷的方法

  我们都知道Adobe Photoshop CS6是业内最知名的图像处理软件,相信朋友们都会在Photoshop美化自己的照片,或制作一些图片.但今天小编来讲一下ps中笔刷的导入方法,用得到的朋友可看一下. 具体方法如下: 1:首先在网上下载好笔刷,然后进行解压. 2:我们打开ps,新建一个合成. 3:下面我们要讲到的就是笔刷工具,在工具栏找到它! 分类: PS入门教程

acm-关于杭电ACM2031 进制转换感觉找不出自己的错误,求指出

问题描述 关于杭电ACM2031 进制转换感觉找不出自己的错误,求指出 #includeint main(){ long nr; char a[10000]; while(scanf(""%d%d""&n&r) == 2) { if(n == 0) printf(""0 ""); else { int i = 0; if(n while(n > 0) { a[i++] = n%r; n=n/r; } in

写给大二想投入ACM的女生

[来信] 您好!我是学计算机的一名大二女生,大一基础学得不好,不注重专业学习,也不知道自己到底喜不喜欢这个专业,浑浑噩噩的就过去一年了,大二想补回来,说不清楚喜不喜欢,适不适合当程序员,但我觉得还是要好好学好专业知识,提高编程能力,在对它有更多的了解之后再判定这些纠结的问题. 最近加入了我们学院的ACM实验室,开始刷acm的基础题目,也想开始发表csdn博客,见证专业学习成长,分享经验心得,您对我在acm学习等方面有建议吗?您认为一个基础差的女生有必要对ACM投入时间吗?大二是很关键的一年,我自

关于“IT学子成长指导”专栏及文章目录

迂者专栏关键词 就 业 大一 大二 大三 大四 自学 职 场 专业+兴趣 研究生 硕士 规 划 考 研 大学生活 迷 茫 计算机+专业 基本功 学习方法 编程 基 础 实践 读书 前 途 成 长 社团 课程 IT行业 奋 斗 CSDN社区对我的专访.再访(一).再访(二).我的大学.Follow my heart,将为IT菜鸟起飞建跑道的事业进行下去. 本博义务咨询纯利用业余时间,本职工作需要优先,故不能保证所有来信在当天能得到回复,有的问题还需要给我留出思考时间.来信只需一封,请不要用一信多发

java-求解答,,,,,,,,,

问题描述 求解答,,,,,,,,, java集合框架的知识,求解答,谢谢了,,,,,,,,,,,,,,,,, 解决方案 你好,作为过来人.我可以以我的简单学编程经历来回答你的问题.不喜,勿喷.若对你有所帮助,望采纳. 先说第一个问题:学习C语言是不是要背呢?或者换句话说?学习编程是不是要背很多东西呢? 我的回答是:学习任何新的东西,首先是要记住一些东西,只有记住了一些东西我们才能入门进行应用.但是并不是说学编程,要向文科一样,要背很多东西.就拿C语言来说吧,咱们开始入门的时候,一定要记住常用的数