问题描述
- 刷ACM小伙伴进Uva oj 340 - Master-Mind Hints
-
如题: Master-Mind HintsMasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.
In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.
In this problem you will be given a secret code tex2html_wrap_inline35 and a guess tex2html_wrap_inline37 , and are to determine the hint. A hint consists of a pair of numbers determined as follows.
A match is a pair (i,j), tex2html_wrap_inline41 and tex2html_wrap_inline43 , such that tex2html_wrap_inline45 . Match (i,j) is called strong when i = j, and is called weak otherwise. Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.
Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.
Input
The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.
Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum value for N will be 1000.
Output
The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.
Sample Input
4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0
Sample OutputGame 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)大概意思就是猜数字的一个游戏,给定答案序列和用户猜的序列,统计有多少数字正确(A),有多少数字在两个序列都出现过但位置不对(B)。 ps.猜测序列正常情况下数字只可能是1~9中的某一个。 输入包含多组数据。每组输入第一行为序列长度为n,第二行是答案序列,接下来是若干猜测序列。猜测序列全零则该组数据结束。n=0输入结束。 下面是我的代码:
#include <stdio.h> int a[1050],b[1050]; int main() { int n,round=0; while(scanf("%d",n)==1&&n){ for(int i=1;i<=n;i++) scanf("%d",&a[i]); printf("Game %d:n",++round); //用round记录第几轮 int num1=0,num2=0; for(;;){ int c1=0,c2=0; for(int i=1;i<=n;i++){ scanf("%d",&b[i]); if(b[i]==a[i]) num1++; //直接统计可得A for(int j=1;j<=9;j++){ if(a[i]==j) c1++; if(b[i]==j) c2++; } } if(b[1]==0) break; if(c1<c2) num2+=c1; else num2+=c2; printf(" (%d,%d)n",num1,num2-num1); } } return 0; }
最后编译没问题,可是出现dos窗口输入一个数字enter后就狗带了
解决方案
你的程序指针有问题,参考
http://www.cnblogs.com/SDUTYST/archive/2012/06/02/2532196.html
http://blog.csdn.net/zcube/article/details/8461796
解决方案二:
第一个while的scanf的n少了&,但是跑完你的答案是不对的。。
while(scanf("%d",&n)==1&&n){
解决方案三:
重新梳理了下逻辑,现在应该行了
#include <stdio.h>
int a[1050],b[1050];
int main()
{
int n,round=0;
while(scanf("%d",&n)==1&&n){
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
round++;
printf("Game %d:n",round);
for(;;){
int num1=0,num2=0;
for(int i=1;i<=n;i++){ //猜测序列赋值
scanf("%d",&b[i]);
if(b[i]==a[i]) num1++;
}
if(b[1]==0) break;
for(int j=1;j<=9;j++){
int c1=0,c2=0; //在每一轮数字统计时初始化c1,c2
for(int i=1;i<=n;i++){
if(a[i]==j) c1++;//c1记录在答案序列某数字的个数
if(b[i]==j) c2++;//c2记录在猜测序列中某数字的个数
}
if(c1<c2)
num2+=c1;
else
num2+=c2;
//c1,c2两者取其小
}
printf(" (%d,%d)n",num1,num2-num1);
}
}
return 0;
}