UVa 264 Count on Cantor (waater ver.)

264 - Count on Cantor

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=200

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input and Output

You are to write a program that will read a list of numbers in the range from 1 to

and will print for each number the corresponding term in Cantor's enumeration as given below. No blank line should appear after the last number.

The input list contains a single number per line and will be terminated by end-of-file.

Sample input

3
14
7

Sample output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4

完整代码:

/*0.016s*/

#include<cstdio>
#include<cmath>  

int main(void)
{
    int n, k, s;
    while (~scanf("%d", &n))
    {
        k = (int)floor((sqrt((n << 3) + 1) - 1) / 2 - 1e-9) + 1;///减少一点再上取整
        s = k * (k + 1) >> 1;
        if (k & 1)
            printf("TERM %d IS %d/%d\n", n, s - n + 1, k - s + n);
        else
            printf("TERM %d IS %d/%d\n", n, k - s + n, s - n + 1);
    }
    return 0;
}

查看本栏目更多精彩内容:http://www.bianceng.cnhttp://www.bianceng.cn/Programming/sjjg/

以上是小编为您精心准备的的内容,在的博客、问答、公众号、人物、课程等栏目也有的相关内容,欢迎继续使用右上角搜索按钮进行搜索enumeration
, numbers
, number
, and
, proofs of ownership
, is
, Mathematics
The
,以便于您获取更多的相关知识。

时间: 2024-10-31 07:11:09

UVa 264 Count on Cantor (waater ver.)的相关文章

UVa 10019 Funny Encryption Method (water ver.)

10019 - Funny Encryption Method Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=960 The Problem History : A student from ITESM Campus Monterrey plays with

UVa 10008 What&#039;s Cryptanalysis? (water ver.)

10008 - What's Cryptanalysis? Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=949 Cryptanalysis is the process of breaking someone else's cryptographic wr

UVa 10921 Find the Telephone (water ver.)

10921 - Find the Telephone Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1862 In some places is common to remember a phone number associating its digits

UVa 10346 Peter&#039;s Smokes (water ver.)

10346 - Peter's Smokes Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1287 Peter has n cigarettes. He smokes them one by one keeping all the butts. Out o

UVa 10656 Maximum Sum (II) (water ver.)

10656 - Maximum Sum (II) Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1597 In a given a sequence of non-negative integers you will have to find such a

UVa 11498 Division of Nlogonia (water ver.)

11498 - Division of Nlogonia Time limit: 1.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=2493 The Problem After centuries of hostilities and skirmishes between the fo

UVa 457 Linear Cellular Automata (water ver.)

457 - Linear Cellular Automata Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=94&page=show_problem&problem=398 A biologist is experimenting with DNA modification of bacterial colonie

UVa 11044 Searching for Nessy (water ver.)

11044 - Searching for Nessy Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=99&page=show_problem&problem=1985 The Loch Ness Monsteris a mysterious and unidentified animal said to inha

UVa 102 Ecological Bin Packing (water ver.)

102 - Ecological Bin Packing Time limit: 3.000 seconds http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=38 Background Bin packing, or the placement of objects of certain weights int