首先路由器的IOS版本满足条件(12.2(5)T以上)
有几种方式:
1、 对于BT完全限制 ( 见下例policy-map XX的不同部分)(采用NBAR)
2、 对于BT的速率进行限制(见下例policy-map XX的不同部分)(采用NBAR)
3、 通过优先级队列完成
一、有地址转换的情况:
ip nbar pdlm bootflash:bittorrent.pdlm (必须先启动)
class-map match-all bt
match protocol bittorrent
!
!
policy-map bt1 (完全丢弃)
class bt
drop
policy-map bt2 (速率限制)
class bt
police cir 50000
conform-action transmit
exceed-action drop
policy-map bt3 (速率限制)
class bt
police cir 300000
conform-action transmit
exceed-action drop
interface FastEthernet0/0
ip address 192.168.34.240 255.255.255.0
ip nat outside
ip virtual-reassembly
service-policy input bt3 (下载限制)
service-policy output bt2 (上传限制)
duplex full
!
interface FastEthernet1/0
ip address 192.168.101.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex full
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.34.1
!
no ip http server
!
ip nat pool pool1 192.168.34.240 192.168.34.240 netmask 255.255.255.0
ip nat inside source list 1 pool pool1 overload
!
access-list 1 permit any
二、没有地址转换:
ip nbar pdlm bootflash:/bittorrent.pdlm
class-map match-all bt
match protocol bittorrent
!
!
policy-map bt2
class bt
police cir 160000
conform-action transmit
exceed-action drop
policy-map bt3
class bt
police cir 240000 bc 60000 pir 350000
conform-action transmit
exceed-action drop
policy-map bt1
class bt
drop
!
!
!
!
interface Loopback0
no ip address
no ip route-cache
!
interface FastEthernet0/0
ip address 192.168.101.1 255.255.255.0
duplex full
!
interface FastEthernet1/0
ip address 192.168.102.254 255.255.255.0
service-policy input bt3
service-policy output bt2
ip route-cache policy
duplex full
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.102.1