hd1028Ignatius and the Princess III【母函数】

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12832    Accepted Submission(s): 9080

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

 

Sample Input


4
10
20

 

Sample Output


5
42
627

算法: 母函数

#include<cstdio>
int main()
{
    int n,i,j,k,a1[130],a2[130];
    for(i=0;i<=120;i++)
        {
            a1[i]=1;
            a2[i]=0;
        }
        for(i=2;i<=120;i++)
        {
            for(j=0;j<=120;j++)
            {
                for(k=0;k+j<=120;k+=i)
                {
                    a2[k+j]+=a1[j];
                }
            }
            for(j=0;j<=120;j++)
            {
                a1[j]=a2[j];
                a2[j]=0;
            }
        }
    while(scanf("%d",&n)!=EOF)
    {
        printf("%d\n",a1[n]);
    }
    return 0;
}
时间: 2024-07-31 09:22:57

hd1028Ignatius and the Princess III【母函数】的相关文章

hdu 1028 Ignatius and the Princess III (母函数)

点击打开链接 Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16394    Accepted Submission(s): 11552 Problem Description "Well, it seems the first problem is too easy. I

HDU1028-Ignatius and the Princess III

Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12789    Accepted Submission(s): 9045 Problem Description "Well, it seems the first problem is too easy. I will let

HDOJ 1028 Ignatius and the Princess III(递推)

Problem Description "Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. "The second problem is, given an positive integer N, we define an equation like this: N=a[1]+a[2]+a[3]+-+a[m];

HDU1028 拆分数母函数

                       Ignatius and the Princess III                                                     Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)                                                                 

实例编程:迷宫探路III

将从迷宫入口到各点的最短路近的集合看作一棵树.用广度遍历的方法即可找到出口的最短路近.本程序算法思想来源于求图上一点到其余各点最短路近的Dijkstra算法. /* 迷宫探路III(最短路径)*/ /* DIJKSTRAMAZE.C */ /* 2003-8-26 */ #include <stdlib.h> #include <time.h> #include <math.h> #include <stdio.h> #include <graphic

Pentium III处理器的单指令多数据流扩展指令(3)

概要 : 随着Intel Pentium III处理器的发布,给程序设计人员又带来了许多新的特性.利用这些新特性,程序员可以为用户创造出更好的产品. Pentium III和Pentium III Xeon(至强处理器)的许多新特性,可以使她能够比Pentium II和Pentium II Xeon处理器有更快的运行速度,这些新特性包括一个处理器序列号(unique processor ID)和新增SSE处理器指令集,这些新的指令集就像Pentium II在经典Pentium的基础上添加的MMX

Pentium III处理器的单指令多数据流扩展指令(2)

关键字 : Pentium,处理器,单指令多数据流扩展指令,SSE,指令集 概要 : 随着Intel Pentium III处理器的发布,给程序设计人员又带来了许多新的特性.利用这些新特性,程序员可以为用户创造出更好的产品. Pentium III和Pentium III Xeon(至强处理器)的许多新特性,可以使她能够比Pentium II和Pentium II Xeon处理器有更快的运行速度,这些新特性包括一个处理器序列号(unique processor ID)和新增SSE处理器指令集,这

Pentium III处理器的单指令多数据流扩展指令(1)

关键字 : Pentium,处理器,单指令多数据流扩展指令,SSE,指令集 概要 : 随着Intel Pentium III处理器的发布,给程序设计人员又带来了许多新的特性.利用这些新特性,程序员可以为用户创造出更好的产品. Pentium III和Pentium III Xeon(至强处理器)的许多新特性,可以使她能够比Pentium II和Pentium II Xeon处理器有更快的运行速度,这些新特性包括一个处理器序列号(unique processor ID)和新增SSE处理器指令集,这

算法题:UVA 10635 Prince and Princess (dp + LCS)

In an n x n chessboard, Prince and Princess plays a game. The squares in the chessboard are numbered 1, 2, 3 ... n*n, as shown below: Prince stands in square 1, make p jumps and finally reach square n*n. He enters a square at most once. So if we use