HDOJ 1013题Digital Roots 大数,9余数定理

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are
summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input


24
39
0

Sample Output


6
3

一个数对九取余,得到的数称之为九余数;

一个数的九余数等于它的各个数位上的数之和的九余数!

题目大意:

 给定一个正整数,根据一定的规则求出该数的“数根”,其规则如下:

        例如给定 数字 24,将24的各个位上的数字“分离”,分别得到数字 2 和 4,而2+4=6;

        因为 6 < 10,所以就认为6是数字24的“数根”;

        而对于数字 39 , 将39的各个位上的数字“分离”,分别得到数字 3 和 9,而3+9=12,且12>10;

       所以依据规则再对 12 进行相应的运算,最后得到数字3,而3<10,所以就认为3是数字39的“数根”。

       

              通过运算可以发现任何一个数的“数根”都是一个取值范围在 1 ~ 9之间的正整数,

     且任何一个正整数都只有唯一的一个“数根”与其相对应。

              题目要求数字 n^n 的“数根”

解题思路:

九余数定理

一个数对九取余后的结果称为九余数。

一个数的各位数字之和想加后得到的<10的数字称为这个数的九余数(如果相加结果大于9,则继续各位相加)

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
int main()
{
    char a[1010];
    int i,j,s,l;
    while(~scanf("%s",&a)&&a[0]!='0')
    {
        l=strlen(a);
        s=0;
        for(i=0;i<l;i++)
        {
            s=s+a[i]-'0';
        }
        s=s%9;
        if(s==0)
            s=9;
        printf("%d\n",s);
    }
    return 0;
}

一个数对九取余,得到的数称之为九余数;

一个数的九余数等于它的各个数位上的数之和的九余数!

时间: 2024-07-31 18:42:16

HDOJ 1013题Digital Roots 大数,9余数定理的相关文章

HDOJ 1163 Eddy&amp;#39;s digital Roots(九余数定理的应用)

Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits a

算法题:HDU 1013 Digital Roots

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the pr

HDOJ 1013 Digital Roots

Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits a

HDOJ 1018 Big Number(大数位数公式)

Problem Description In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of

HDU 1006 Digital Roots

Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits a

HDOJ 1753 大明A+B(大数~)

Problem Description 话说,经过了漫长的一个多月,小明已经成长了许多,所以他改了一个名字叫"大明". 这时他已经不是那个只会做100以内加法的那个"小明"了,现在他甚至会任意长度的正小数的加法. 现在,给你两个正的小数A和B,你的任务是代表大明计算出A+B的值. Input 本题目包含多组测试数据,请处理到文件结束. 每一组测试数据在一行里面包含两个长度不大于400的正小数A和B. Output 请在一行里面输出输出A+B的值,请输出最简形式.详细

HDOJ 1312题Red and Black

Red and Black Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13508 Accepted Submission(s): 8375 Problem Description There is a rectangular room, covered with square tiles. Each tile is colored ei

HDOJ 1013

//wa的代码,既然说是整数,应该不用考虑大数,可实际上却要考虑大数   #include<stdio.h> int main() { int num,temp; while(scanf("%d",&num),num) { temp=num%9; printf("%d\n",temp); } return 0; } //或者mod9,若是k,则各个数字和为k   //既然说是整数,应该不用考虑大数,可实际上却要考虑大数   /*超时代码 #inc

HDOJ 1004题 Let the Balloon Rise strcmp()函数

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color