HDOJ 1018 Big Number(大数位数公式)

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19

这题要求n的阶乘的位数,如果n较大时,n的阶乘必将是一个很大的数,题中说1<=n<10000000,当n=10000000时可以说n的阶乘将是一个非常巨大的数字,对于处理大数的问题,我们一般用字符串,这题当n取最大值时,就是一千万个数字相乘的积,太大了,就算保存在字符串中都有一点困难,而且一千万个数字相乘是会涉及到大数的乘法,大数的乘法是比较耗时的,就算计算出结果一般也会超时。这让我们不得不抛弃这种直接的方法。

再想一下,这题是要求n的阶乘的位数,而n的阶乘是n个数的乘积,那么要是我们能把这个问题分解就好了。

在这之前,我们必须要知道一个知识,任意一个正整数a的位数等于(int)log10(a)+ 1;为什么呢?下面给大家推导一下:

对于任意一个给定的正整数a,
假设10^(x-1)<=a<10^x,那么显然a的位数为x位,
又因为
log10(10^(x-1))<=log10(a)<(log10(10^x))
即x-1<=log10(a) < x
则(int)log10(a)=x-1,
即(int)log10(a)+1=x
即a的位数是(int)log10(a)+1

我们知道了一个正整数a的位数等于(int)log10(a) + 1,现在来求n的阶乘的位数:
假设A=n!=1*2*3*……*n,那么我们要求的就是(int)log10(A)+1,
而:
log10(A)=log10(1*2*3*……n)
(根据log10(a*b) = log10(a) +log10(b)有) =log10(1)+log10(2)+log10(3)+……+log10(n)
现在我们终于找到方法,问题解决了,我们将求n的阶乘的位数分解成了求n个数对10取对数的和,并且对于其中任意一个数,都在正常的数字范围之类。
总结一下:n的阶乘的位数等于
(int)(log10(1)+log10(2)+log10(3)+……+log10(n)) + 1

开始我是打算用java大数做的,可是超时。
上面的思路是参考网络上其他人的。

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {

        //超时
//      Scanner sc = new Scanner(System.in);
//
//      int t = sc.nextInt();
//      while(t-->0){
//          int n = sc.nextInt();
//
//          BigDecimal a  = new BigDecimal(1);
//
//          for(int i=n;i>0;i--){
//              a = a.multiply(new BigDecimal(i));
//          }
//
//          String str = a.toPlainString();
//          System.out.println(str.length());
//
//
//      }

        Scanner sc= new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int n = sc.nextInt();
            double sum = 0;
            for(int i = 1;i<=n;i++){
                sum = sum+Math.log10(i);
            }
            System.out.println((1+(int)(sum)));
        }

    }
}
时间: 2024-09-30 14:49:40

HDOJ 1018 Big Number(大数位数公式)的相关文章

HDOJ 1266 Reverse Number(数字反向输出题)

Problem Description Welcome to 2006'4 computer college programming contest! Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one- Ha-

HDOJ(HDU) 2519 新生晚会(组合公式)

Problem Description 开学了,杭电又迎来了好多新生.ACMer想为新生准备一个节目.来报名要表演节目的人很多,多达N个,但是只需要从这N个人中选M个就够了,一共有多少种选择方法? Input 数据的第一行包括一个正整数T,接下来有T组数据,每组数据占一行. 每组数据包含两个整数N(来报名的人数,1<=N<=30),M(节目需要的人数0<=M<=30) Output 每组数据输出一个整数,每个输出占一行 Sample Input 5 3 2 5 3 4 4 3 6

HDOJ 1212 Big Number

Problem Description As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B. To make the problem easier, I promise that B will be smaller than 100000. Is it t

Excel 工程函数

本篇关于介绍Excel 工程函数 1.BESSELI 用途:返回修正Bessel函数值,它与用纯虚数参数运算时的Bessel 函数值相等. 语法:BESSELI(x,n) 参数:X为参数值.N为函数的阶数.如果 n 非整数,则截尾取整. 2.BESSELJ 用途:返回 Bessel 函数值. 语法:BESSELJ(x,n) 参数:同上 3.BESSELK 用途:返回修正Bessel函数值,它与用纯虚数参数运算时的Bessel 函数值相等. 语法:BESSELK(x,n) 参数:同上 4.BESS

ava 自守数-关于自守数,一个测试用例通不过

问题描述 关于自守数,一个测试用例通不过 自守数 如果某个数的平方的末尾几位数等于这个数,那么就称这个数为自守数. 显然,5和6是一位自守数(5x5=25 6x6=36),25x25=625 76x76=5776,所以25和76是两位自守数. 详细描述: 接口说明 原型: Public static boolean isAutoMorphicNum( int num) 输入参数: num 需要判断的数 输出参数(指针指向的内存区域保证有效): 无 返回值: true 是自守数 false 不是自

自守数算法----C语言实现

#include <stdio.h> //自守数算法 //ep : 25 ^ 2 = 625 76 ^ 2 = 5776 9376 ^ 2 = 87909376 /*ep : * 376 被乘数 * *376 乘数 * ------ --------- * 2256 第一个部分积=被乘数*乘数的倒数第一位 * 2632 第二个部分积=被乘数*乘数的倒数第三位 * 1125 第三个部分积=被乘数*乘数的倒数第三位 *-------- * 141376 将以上的部分积的后3位求和后截取后3位就是3

javascript自动生成包含数字与字符的随机字符串_javascript技巧

本文实例讲述了javascript自动生成包含数字与字符的随机字符串的方法.分享给大家供大家参考.具体如下: 这里主要用到Math.random() 和 Math.floor() 两个函数 Math.random()   -- 返回0和1之间的伪随机数 可能为0,但总是小于1,[0,1) Math.floor()    -- 向下取整,舍掉小数字后的值 实现随机多位数的方法: 复制代码 代码如下: /** * *    随机生成数字 * *@param num 生成数字位数 */  functi

PL/SQL 类型格式转换_oracle

TO_NUMBER(char[,'format_model'])  字符转换到数字类型 TO_DATE(char[,'format_model'])  字符转换到日期类型   格式说明符:要与前边要转换的字符串的格式要相同才能转换(匹配问题:格式和位数). TO_CHAR(date[,'format_model'[,nlsparams]])   第二个参数可以省略,不指定格式,按系统默认格式输出.   区分大小写.   使用FM(在格式控制符前添加)符号可以去掉空格或是首位的零.   如果指定了

java计算自幂数和水仙花数_java

(例如:当n为3时,有1^3 + 5^3 + 3^3 = 153,153即是n为3时的一个自幂数)n为1时,自幂数称为独身数.n为2时,没有自幂数.n为3时,自幂数称为水仙花数.n为4时,自幂数称为玫瑰花数.n为5时,自幂数称为五角星数.n为6时,自幂数称为六合数.n为7时,自幂数称为北斗七星数.n为8时,自幂数称为八仙数.n为9时,自幂数称为九九重阳数.n为10时,自幂数称为十全十美数. 复制代码 代码如下: /* * 自幂数 * 自幂数是指一个 n 位数,它的每个位上的数字的 n 次幂之和等